1.1.5 sync issues

I can not get synced for the last few days. I’m trying to re-download full db from snapshot, but the diff is around 600 mb downloading more than 24 hours already.
It looks like something is not working. I have tons of connections, leechers, but I can not download anything, progress is crazy slow and I am not sure that it will be finished at all. Just syncing… Can’t farm with almost 300 plots, and it is started 2-3 days ago with 1.1.5 version.

2021-05-16T18:37:33.424 wallet chia.wallet.wallet_node    : ERROR    Loop exception in sync Was not able to add blocks 29803-29835. Traceback (most recent call last):
  File "chia\wallet\wallet_node.py", line 509, in sync_job
  File "chia\wallet\wallet_node.py", line 606, in _sync
RuntimeError: Was not able to add blocks 29803-29835

2021-05-16T18:39:51.034 full_node full_node_server        : WARNING  Trying to ban localhost for 10, but will not ban
2021-05-16T18:39:51.090 full_node asyncio                 : ERROR    Task exception was never retrieved
future: <Task finished coro=<ChiaServer.incoming_api_task.<locals>.api_call() done, defined at chia\server\server.py:482> exception=CancelledError()>
2021-05-16T18:39:54.235 full_node chia.full_node.full_node: ERROR    Error with syncing: <class 'ValueError'>Traceback (most recent call last):
  File "chia\consensus\blockchain.py", line 262, in receive_block
  File "chia\consensus\blockchain.py", line 360, in _reconsider_peak
  File "chia\full_node\coin_store.py", line 81, in new_block
  File "chia\full_node\coin_store.py", line 245, in _add_coin_record
  File "aiosqlite\cursor.py", line 69, in close
  File "aiosqlite\cursor.py", line 31, in _execute
  File "aiosqlite\core.py", line 129, in _execute
  File "aiosqlite\core.py", line 102, in run
sqlite3.ProgrammingError: Cannot operate on a closed database.

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "chia\full_node\full_node.py", line 659, in _sync
  File "chia\full_node\full_node.py", line 725, in sync_from_fork_point
  File "chia\full_node\full_node.py", line 803, in receive_block_batch
  File "chia\consensus\blockchain.py", line 278, in receive_block
  File "chia\util\db_wrapper.py", line 24, in rollback_transaction
  File "aiosqlite\core.py", line 258, in in_transaction
  File "aiosqlite\core.py", line 67, in _conn
ValueError: no active connection

Hmm. It looks to me like

Loop exception in sync

is perhaps the error that you are facing?

1 Like

thanks for reply! probably… after 3 days of struggling finally I got synced status but I not sure for how long.
I noticed that while I’m getting those errors in windows GUI for connected peers there is no block height, empty lines, but tons of connections with up/down values. I uploaded around 18 GB of data for leechers during the days I was not able to get synced. And this is weird. Everything is working like a charm from my side for sure. I hope for some updates soon, since windows client is a mess right now :frowning:

1 Like

After 3 days out of sync I was able to get synced… for 5 hours. Now again I’m out of sync :frowning:

I am in the same boat… Been trying to Sync for 3-4 days now. No luck. My block count keeps incrementing but VERY slowly. I’ve tried everything I can find on the forums. Hopefully something will come up for you that might help me?

I’m having the same problem as you guys, just can’t keep in sync, block count incrementing very very slowly.

I’ve tried LAN and WiFi connections, deleting .chia folder, blocking all CN traffic via firewall, disabling firewall, installing windows update and rebooting, restarting the app hundred times, disabling 8444/enabling 8444 - no way…

I’ve been using “chia show -a introducer-va.chia.net:8444” from time to time to kick off the sync process when it stalls out… Still never catches up but at least its trying after this. Think I am going to make a script that kicks off ever 15-20 minutes to run this command.

Got it from “Speed up connecting to nodes” at

I see several people stating they have the issue, But no one stating they have a solution.

simple reason: cause there is no solution! Something is temporarely f***ed up as we speak, and this should honestly be announced on CHIA-home or keybase - but not the slightest hint or warning is given, so my conclusion is devs dont care for some whiners not beeing synced, respectively have more important things to do (update end of may).

There is nice script: https://www.reddit.com/r/chia/comments/nebcez/an_effective_workaround_for_continous_desync/

It’s working, I’m testing it right now, will see how this will help us to maintain lack of client development :smiley:

For now, I just setup a script that connects to all the introducers hourly… Im VERY close to being synced now… Maybe that will work?

I’m in this boat for 3-4 days now, and I agree there should be a pinned post or a note in Chia keybase. Doesn’t matter if they don’t have a solution yet, just set a flag for people to follow.

There’s a nice one liner for Linux posted on that same Reddit.

dig +short -t a dns-introducer.chia.net | xargs -I{} chia show -a {}:8444

I have that running in an hourly cron job now.

Still need to get something similar running on my windows machine. I would prefer not to need to install something to get a python script working for something so simple and hopefully temporary. Needs to see if I can write in the Powershell or even simple batch file.

Update: continuously adding up-to-date synced nodes (I was using script above from the reddit fetchNodes.py) did not help. After few hours I am already “Not synced” and stuck again.

Side Note. I want to make those dashboards… I started looking into it. Got overwhelmed. Is is fairly simple?

On the Syncing subject… my largest farm is almost synced… I’m sure it will fall out of sync. We cant be the only ones experiencing this.

Side Note. I want to make those dashboards… I started looking into it. Got overwhelmed. Is is fairly simple?

It is very simple.

  1. Install node.js
  2. Open https://dashboard.chia.foxypool.io/ - create satellite and and copy API key
  3. Open Nonde.js command line and: npm install --global chia-dashboard-satellite
  4. enter your API key when asked
  5. open https://dashboard.chia.foxypool.io/ to check satellite

I just checked a buddy of mine, His rig only has 8 plots and its perfectly synced.

Wonder if have a large number of plots has something to do with it?