1.3.3 possible memory leak

Not looking for advice, just a warning to anyone else on this release.

Been getting some slow response times, could be a bad drive, needs further investigation.

I noticed though my pc was using over 20gb of ram, and it was slowly creeping upwards.

Had to force close as chia wouldnt shut down gracefully, no db corruption thankfully.

Rebooted pc, did win updates and rebooted pc agn, chia is now using just under 7gb ram which is more where it should be.

So if your on this release, its something to watch for.

Ill update once i know if that was causing my poor response times.
Shouldnt have, as i have 32gb in that box, but easier to rule that out first.

1 Like

Not looking for advice, just a warning to anyone else on this release.

I’ve been having some resource issues with Windows Vista: regular reboots seem to keep it under control though. So if you’re also using Vista, its something to watch for.

Don’t tell me to upgrade: you’re not my mom!

1 Like

After forcing Chia to close, but before re-booting, how much RAM was recovered?

I was running 1.3.3 for two or three months (maybe longer – I don’t remember), and it ran smoothly on my Windows 10 Home system.

1 Like

No, no, never upgrade… you are a piece of Windows most maligned history, to be viewed in awe by the multitudes that have dared to go where…I don’t know… somewhere :blush:

2 Likes

I didnt pay attention, i had to enter task mgr and close all chia bits down, task mgr was still showing 56% mem used, all of it was chia, i then rebooted straight away.

Ive been running it since before the fork without issue, my first thought when i noticed it before the weekend wss a dust storm, but mempool was very low so that wasnt happening.

Only chia and farmr run on that machine.

2 Likes

Would you listen to your father? Do I have to put on the black helmet and breath hard???

1 Like

My times are much better sfter 24 hrs, under .1% over 5s and mem at 6.8gb used.
Before reboot i had responses over 30s a few days on the trot.
Bit early to be sure, but looks like theres no poorly drives and it was just a mem issue.

1 Like

Only a few days later and my mem usage creeps up daily, currently at 7.5 gb.

Ill upgrade client at some point soon.

1 Like

7.8 today, id say theres def an issue.

1 Like

Your version is kind of old, and not too many farmers are still on it (~3%) so you will not get much help.

V1.3.5 is basically identical, but potentially a bit more stable. For me, that upgrade was one of the smoothest. Maybe bump it up to that one, when you have time and hopefully the problem will go away.

1 Like

Wasnt looking for help, just leaving a record incase anyone is still on it as a warning to them.

Ill update soon.

2 Likes

Under 2 wks and ram usage nearly doubled up to 13.5 gb used from 7.

Must find upgrade time on the weekend.

1 Like