1 pc plotter + 1 raspberry

I started plotting on a windows pc in a pool, now moving these hdd to a raspberry fails to farm. The raspberry pi is synchronized, and obviously both PCs have the same mnemonic. The plots are in the ‘plots not found’ state. In the windows pc I am plotting by inserting in the last parameter the alias of the nft plot (from the chia gui)

On your Pi,

  • Are you using GUI or CLI?
  • Did you remember to add the plot directories to chia? See: chia plots show

I use chia gui on raspberry, and yes I have added all directories. I tried to create now a plot with madmax on windows and in that case it works …

In the chia gui on windows I have not set the farmer’s public key in the advanced settings (in plot section)
could this be the reason?

That shouldn’t be a problem. If memory serves, you don’t need this unless you’re plotting on third-party plotting software (like madmax).

I do know there is an issue with the GUI (especially on Linux) where plots aren’t showing in the GUI (but are loaded and can be verified on the CLI).

You might want to open the logs and see if the plots are loading properly. (You might need to set you logs to show INFO level messages first)

if you mean the info that returns the ‘check plots’ I get back a message of this kind.
farmer public key that is not in the farmer’s pk list

I tried to create a plot from a third computer, and move this plot to the windows pc, but it gives the same problem, so I exclude that the problem is on the raspberry

Pretty sure that means your keys aren’t loaded… you sure you added the correct mnemonic?

the mnemonic is correct because it automatically recovered the alias created in the nft plot section of the gui after synchronization

ok thats weird.

So plot nft shows, wallet shows? Everything with your account is correct but it still complaining the keys aren’t correct for your plot, even though it works and farms correctly on windows pc?

exactly, it is as if it only recognizes the plots made by the pc itself

Well, I’m stumped. No clue what could cause this.

all day looking for a solution, it’s really very strange

I’m reading about someone who had a similar issue and fixed it on reddit.

Apparently to fix this you need to backup your /db and wallet/db files, reinstall chia (I’m assuming you would need to delete the .chia directory as well), log in with your keys, close chia, copy your db files back to the new installation, run chia init and hope it works.

Hey is there a reason you want the raspberry to be farmer?

I have a similar setup pc farmer/plotter and I use the raspberry as a harvester.

  1. there is no need to install keys on the the rasp for security reasons.
  2. the raspberry needs the client so you can just execute “chia start harvester” command.
  3. you need to edit the config file of the chia client on the rasp to point to the farmer computer.

That is all and runs very good all this is on the oficial Chia harvester setup.

Have a read there are a couple more of steps.
Then using “chia farm summary” from the farmer pc you can see how many plots are being farmed on each pc that is the way you monitor the network.