256 buckets not working

Hi guys,

I’ve been reading about plotting optimization and found that the number of buckets could be a good config if you are short on RAM. I tried to use 256 as I read on “Chia plotting basics” but I got an error. Any clue why I received that?

image

Did you try with 128? 1 plot needs 3400 MB at 128. Do you have less than 3400 MB of RAM?

1 Like

128 runs ok but slow if parallel.

I will try parallel ploting but I have only 8GB RAM and using fast CPU and HD.

Sounds like my plotting is limited because of my RAM size.

I wonder to run 4 plots in parallel to get maximum from all my pc components.

You are limited by the RAM. You need 3400 MB per plot, so you can do 2 in parallel.

You’d use -b 3400 in your settings. You don’t need to set -u 128 since that’s the default.

Yep but I was just trying to follow the instruction on “Chia plotting basics” that said to increase buckets for restricted RAM pcs

Hello, I wrote that article. I thought that maybe you could increase the bucket size to 256, but the software actually prevents it. I’ll update the article with this information.

I’m investigating into why that is because it would help people who are ram limited (like me).

3 Likes

Are we really sure people should be messing with buckets in this day and age? Keep It Simple, and all that?

I was thinking the same without checking. The limit however been set at 128 since chiapos version from September 2020, in kMaxBuckets in pos_constants.hpp. From the commit:

Num buckets can vary from 16 to 128. The small one is preferred, since it reduces seeks on disk. For HDDs, more memory is important, so that we can keep the bucket size low.

I don’t know if usort’ing 2 smaller buckets is faster than QS’ing 1 larger bucket.