4 xch is missing

Hello everybody,
Just needed to reboot my farmer and chia 1.3.4 in windows loaded fine and everything is connected and synced just fine. But my April earning which is 4 xch is missing from my wallet. I’m very confused. Any ideas. Help Please

Are you synced back up?

Yes. The sync is done and connected.
But at the top right corner the connected is green but it use to have a number 5 infront of it but now it says 1.

Give it some time (an hour or two), if it will not improve, kill your wallet db, and have it rebuilt. Also, check what is the latest transaction being processed by your wallet (no clue how to check it on v1.3.4 or CLI). If it is not the current, it implies that wallet is still syncing, even though it may show that is fully synced.

Although, depending on the size of your farm, you may want to consider going back to v1.3.3.

1 Like

Isn’t wallet progress / sync shown under tokens in .3 4?

No. I don’t see anything

Mine changes numbers, don’t why?

CLI commands would be good for people to add to a cookbook…

Jacek asked “Although, depending on the size of your farm” So how many disks are you running etc if we can ask, have harvesters etc. All machines have static IP’s and good free space on all?

Close chia gui. Restart your system. Delete only sqlite file in wallet directory. Start chia and wait until sync.

As I wrote (and some other folks also mentioned in other threads), with potentially v1.3.x, synced has two meaning. You could be synced, but not really up to the point to show the latest transactions from the wallet. Therefore, you need to wait those few extra hours to eventually clear things up.

As far as that number, I have not tried v1.3.4, so cannot say for sure, although if that is your wallet, that shows how many full nodes your wallet connects to. When you are upgrading (your v2 db is not yet fully synced), your wallet makes few (3 or so) connections to other full nodes. However, once your v2 db is fully synced, it drops those connections, and just sticks with your full node (a trusted / preferred one).

Again, that output doesn’t mean much, especially for v1.3.4

1 Like

Dont try 1.3.4. It is worse. I reinstalled 1.3.3 because 1.3.4 very slow when you click another menu button, gui hangs and loads sooo slooowly.

You are the MAN.
I did as you instructed and it worked like a charm.
Thank you :pray:


You are absolutly right. Thank you.:pray:

Their working on it, This ones not to bad…

When I click on the tabs on the left it goes to them right away.

I don’t understand why wallet is under full node. Those two things have not that much in common. Basically, full node has no business to connect to any wallets (thus display any wallet info), and wallet doesn’t care which full node it connects to (putting aside trusted nodes).

I would rather imagine that UI should let us start just the full node and monitor the farmer. And, it would allow to chose which wallet to connect to, or show all available wallets. There is no need to provide fingerprint (by UI) to full node, and farmer gets needed info without UI present. On the other hand, wallet requires fingerprint, so why not display everything but wallets (unless explicitly requested), and make it more secure.

Is it safe to install beta versions?

They are Beta versions not Release Versions for a reason.

I have my release version machines and I have my beta test machines. When I run beta I see if it blows up anything, if so I didn’t kill the farm, but got to try the new version before they say" Here it is".