Access to gui on Raspberry Pi OS 64bit

Hi there,
I have a problem accessing remotely the GUI of RasPi OS 64bit.

I am trying with realvnc, but i experience difficulties connecting.

Details:
Raspberry Pi 4, 8gb ram,
Raspberry Pi OS 64bit ,

Please advice what is the best solution you are using ?

Thanks in advance!

I’ve noticed that last 64bit I installed did not include any window manager so make sure you can run xserver locally first using HDMI output before attempting remote connection.

I’m sure @kreaninw made a how-to for this…

Ah, its for Ubuntu. It might help? But I’ve never tried it.


Here is a selection of solutions that other people have tried…

TeamViewer and Google Remote Desktop seem to be quite popular.


And then there’s this…

1 Like

Every famous remote desktop clients on Linux seem to be using the VNC protocol, including TeamViewer, RealVNC, NoMachine, etc. They do not support headless remote, and they do not support login/lock screen. They’re full of issues.

Please use xrdp for the RDP remote connection instead :sweat_smile:

1 Like

I had assumed the OP was using a display.:man_shrugging:

Does VNC not work if one isn’t plugged in, even if its a desktop version of linux? I’ve never tried.

Yes, the VNC will not work without a display/dummy attached. I heard that the GNOME team is working on this and also the RDP on Wayland.

1 Like

Hi, thanks for all the answers.

Do i need a monitor pluged in for Chrome Remote Desktop?
(btw, i changed my PI4 OS from Raspberry Pi OS 64bit to Ubuntu Desktop 21.04 64bit.)

1 Like

For truely headless, in the past, I have used VGA dummy plugs like:

or HDMI dummy plugs like:

They make displayport versions but I had issues with ones like:

They basically have just enough circuitry in them to trick the computer into thinking a full 1080p monitor is plugged in and displaying. Then you can mirror a full display (with most of the display settings in tact) over RDP.

Today, on my server, it is connected to a wall mounted TV where the TV does TV duties most of the time and the PC at my desk or my laptop RDP into it to do anything. The TV just being connected every so often acts as “the head”.

No micro-hdmi one for the RPi4? Fail. :joy:

Try this:

It is a micro to full size HDMI.

If you ever want the option of having a display on the Pi, get a HDMI Y cable like:

and connect the headless HDMI adapter to port 1. Port 2 you can use to connect monitors. Y splitter connects to the micro to full size HDMI cable adapter.

That may work?

Save the money, use xrdp, done :sweat_smile:

Yeah. I agree but I was posing another suggestion just in case there was other things that needed to be done with the Pi that needed a headless adapter. I can’t think of any reason someone would get what I suggested due to xrdp, other than to keep using what they are already using for remoting in.

1 Like

Hi, I have same raspberry and same os with the gui working. I have no monitor pluged. You need to enable ssh and vnc the first time you access the raspnerry pi os. After that modify the config.txt file to allow enable hdmi output without hdmi cable connect. I can acces using vnc viewer remotely inside my net lan or accesing throw vpn to my house using wireguard vpn installed in other central raspberry that I have.

2 Likes

Another reason to avoid VNC is that the shift key could randomly get struck on the VNC session.

For anyone who wants to remote their device with GUI, please use RDP for a hassle-free experience. It’s also a lot more secure due to the fact that you would have to sign out of the local session if you want to use a remote session and vice-versa.

In VNC, you will have to log in and you can’t even use a lock screen. That’s not a good idea to set up the server to use, especially, when you are not at home.

I’m connecting to my raspberry pi which is running ubuntu 64 → windows remote desktop or even from Mac using the windows remote desktop client as well. It works fine.

One silly issue I ran into when setting it up, was that while I was logged into the PI physically with keyboard and mouse it will not allow me to take the session. So all I needed to do was logout, and then it would work fine. From windows you can remotely take the session in case this was not obvious for anyone.

But as said on previous answers windows or mac → to ubuntu RDP works great.

I should have probably asked this in the first place but why do you want to access the desktop on your PI remotely any way? If it’s to use Chia GUI then I would say don’t bother. I use CLI commands with my PI farmer+node for everything over SSH and the only thing I use HDMI is to run Chromium in kiosk mode do display stats on a 7” LCD near my farm :wink:

The only thing I end up doing from time to time is transfer CHIA to my cold wallet from the farmer but if anyone knows if I can change the payout address in the plot NFT to the cold wallet then that would help me solve that task.

1.2.3 has this in the gui and you can change it manually in the config file. You need to convert the puzzle hash to the address or vice-versa. Or you could just run our farmer and enter your exchange/cold wallet address :smiley:

Not everyone is comfortable with CLI. Considering that Raspberry Pi can run GUI perfectly fine, there’s nothing wrong with this idea :sweat_smile: