After updating from 1.2.11 to 1.3.4 on Windows

After the update, I started up the GUI.
It presented me with my wallet (or key code (I do not remember the exact wording)) to click on to log-in. Aside from a minor scare (at the end of this posting), all went well. All of my XCH showed up and all of my plots showed up. It took a minute or two to sync, and I was in business.

Two problems:

  1. When I clicked on the “Farming” button, along the left-hand side, the application hung.
    I waited 2 or 3 minutes. The application turned 100% white, except for the menus, atop.

I was able to exit the application, sort of. The Window shrunk, as if it was closing. But it did not. Clicking the “X”, it closed. taskmgr.exe confirmed all chia related processes were gone.

  1. I started up the GUI, again. This time around, it is not offering me my wallet to click on.
    It is offering 1) Create A New Private Key, 2) Import From Mnemonics (24 Words), or 3) Delete All Keys

Two questions:
– Regarding #1, above: Did anyone else have the hanging issue?

– Regarding #2, above: Before I enter my mnemonics, I thought it best to ask in this forum.
I never had to enter my mnemonics after a Chia upgrade. So I want to check if this is normal going from 1.2.11 to 1.3.4.

Why did I get the option to click on my wallet on the initial 1.3.4 start-up, but now that is gone?
Is this normal?

I am concerned that maybe I am being duped into giving my 24 words to someone?

The minor scare was that the new version presented me with 0 XCH.
It took 5 or 10 minutes to present me with my proper number of XCH.

I was “this” close to stopping the GUI, deleting my wallet DB, and restarting the GUI.
I was fearful that I had installed malware that got my XCH. Not cool to install a new version, and not see your XCH for several minutes, and the installer gives no heads-up. Is that the experience others have had with the upgrade?

Most likely, chia didn’t really fully exited, and wallet process was still sitting on db, or wallet db got corrupted (less likely). When you use task manager, you need to scroll through the second block, as when those processes got orphaned, they move there. Try rebooting.

1 Like

Good call!

There were several chia processes running, including wallet related processes.
I right-clicked the parent of the list of processes, and task manager allowed me to “End Task”.

They all went away.

I started up the GUI, and my wallet / key was there. I clicked on it, and I am in.
But once again, 0 XCH.

Is it normal in the 1.3.x versions to not see your XCH balance for a few minutes?

Don’t know anything about v1.3.4 (remember, I am waiting for v1.3.5+), but with 1.3.1/3, the wallet has four states: not connected, syncing, synced, really synced. The last one was taking few extra minutes. No clue how to tell synced from really synced, though.

But when you start your GUI, does your XCH show a zero balance? Does it take some time to reveal your correct balance?

Also, my “Farming” problem is back.

Shortly after starting the GUI, the “Farming” button works. It shows zero plots, and that is to be expected. Previous Chia versions also took some time to read in all of the plots and deliver a correct plot count.

But nothing hanged. I could click the “Farming” button and other buttons, and the application would display the associated screen.

But once my plots got recognized (once it game me my correct plot count), then when I pressed the “Farming” button, the application hanged.


That’s the difference between synced and fully synced. Until it gets fully synced, your balance is not there or partial. Just give it 30 minutes or so.

1 Like

I am having other issues, for which I will be making a post in the Support area.


I was also 1.2.11 before. You should upgrade 1.3.1 first and wait and see, not 1.3.4 immediately. I have more than 800t. Don’t believe the latest official version. It will make you a white mouse.

I wanted to install version 1.3.3. But lists only the latest version.

You mean, you didn’t scroll down the page?

Yes, I looked everywhere on the site.

The closest I found was a page for release notes for previous versions.

That took me to a github page. I was not sure about downloading from anywhere other than

If you really can’t solve the problem in the end, I suggest you uninstall and reinstall 1.2.11, wait until the database synchronization is successful, and then install 1.3.1 and 1.3.3. The premise is that you back up the whole node and wallet database of 1.2.11.

Some others had coin balance showing improperly.
Sometimes a wallet resync fixed it, some resynced both db’s.

I have never read of anyone back-revving their Chia version.

Unless I read that people have done it, without issues, I will not risk it.

I would love to go back to 1.2.11, and then upgrade to 1.3.1, and then 1.3.3.
But that back-revving is a risk I will not take, unless I find out that it works.

I will consider shutting down the GUI, renaming my Wallet, and then starting the GUI.

I am assuming that when Chia does not find the wallet, I will have to enter my 24 words and Chia will re-create the wallet from the blockchain file?

I’m was only talking of deleting ( or renaming and moving ) the wallet db, not your keys.
Which would just resync pretty fast.
No need to re enter mnemonic.

I have no idea what will happen in the scenario you’re thinking of.

I thought that that was the procedure. I am glad I wrote out the steps and you alerted me that it is wrong.

How do you get Chia to re-sync the wallet, if you do not remove the wallet?

Just delete the wallet db, or rename and remove it.

It will resync itself with no thing needed from you.
And is fast on the latest releases.

That is what I wrote that I would do. Or is one or more of the steps that I wrote different or in error?

All this is one of the reasons I run several full nodes. I try new versions out on a full node that is not farming first.