Anybody else got an issue with chia and forks eating more and more ram?

Hey all,
anybody else got the issue, that the chia gui and other forks eating more and more ram after time?
Starting from 13gb and now at 20gb, still rising hourly.
Would be nice if i could get rid of it, don´t wanna restart my system after few days.
I´m using Linux mint with 24gb ram
And pooling on foxy pool

I’m running chia and six forks concurrently on a machine with 32 gb and doesn’t run out of ram anytime.
But I run only the cli versions without the bloated gui.

Are you using the gui versions for all forks?

1 Like

Yep, doesn´t know how to cli them. Do you got an command for this, i will try this instead.

Depends on what you’re doing on this machine.
I run chia and all forks only with (starts: full_node, farmer and harvester):

. /path/to/chia-blockchain/activate
chia start farmer-no-wallet

Checkou chia start --help for other service collections…


Ok, thanks i will give it a try

Thanks a lot mate. Got now running a script that runs me all farmer and got only 10gb ram eaten, will watch it until tomorrow and give some feedback.
Great helping, big thanks again.

Hey, still got the ram eating, but not as fast as with the gui, sooo i think it will be ok. just 1 restart in a week instead of all 3 days 1.
Thanks anyway for your help :smiley:

Hmm, what else have you running? How does you see it’s eating ram? What is your indicator that you have to reboot your machine?

Do you mean “free” ram of the command free or top?
Linux does use available free ram for file caching that gets freed if you nedd that ram for other purposes…

I’ve three VMs running beside the mentioned forks on my host os and rebooted the server last time in juni.

I´m using glances for monitor, and i knew that i have to restart, becouse i got no response from anydesk.
If im going to the pc, and try to move the mouse nothing happens, linux freeze.
so i guess it can only be from the non avaible ram, got no other excuses for this.
instead of direclty getting lost 15gb ram, with cli it only uses 9gb at start.
No nothing other running than chia and the forks.

This should never happen also if your pc runs out of ram.
Linux shouldn’t freeze, instead it should kill the resource hungry process or do a reset.
This sounds more like a hardware fault.

Can you open the text console on the local console to watch for any kernel event?
To switch from desktop console to text console you need to press “strg + alt + f1”.
Depending on you linux distro the gui console should live on “strg + alt + f2-f12”.
If any kernel event fires you will see it on the text console.

1 Like

Sure thing, just have to wait until it happens again, will post again after that.

[ running 64 core amd with 128gb ram, and 3 nvmes ]

yep, I’m not seeing this I have six forks, and hpool, and foxy-pool og flax, and I never go over 2gb, unless I run mad-max then I go to 8gb

I think you have a massive ‘bot’ or virus in your system, reboot and clean, get ‘bleachbit’ to clean all the crap, and review the startup /etc/cron for all processes and see if anything don’t belong there

Run HTOP sort by memory and verify exactly which crap is taking the memory

IMHO the problem with all thee shitty-clones is that they leave dormant processes, and they all need to be ran in a sandbox

For now reboot your system
IN the future when you stop a clone say flax say ( or any shit clone of chia )

flax stop all
flax stop -d all
ps -ax | grep flax | awk “PID” | kill -9

Lots of these damn clones are not closing all the processes when you stop, and then they stick around accumulate and will burn up your memory.

My linux freezes when I run madmax, so I deal it down to -r 4, (64 core) it wants it all

‘linux shouldn’t freeze’ yep tell that to my servers

when I run mad-max which the only time I see freeze I use nice -n chia-plot …

Then ps -a | grep chia-plot , sudo ionice -p PID -c 3; which tells the mad max to only consume io at idle
The nice says only consume cpu at idle and I run -r 4 on max, and I don’t do all the above my system freezes when mad max writes the final files;

Clearly madmax is doing a “disable interrupt”
Which is why its so fast, without the nice, ionice I get 15 minutes for a plot, with the nice&ionice its 20 min, not much of a loss for a useable system

BUt I agree, other than mad-max your system should not be freezing.

It´s just a bit strange that the chia full node, is running like 10x. And the forks too, sooo why i just can´t have 1 full node for each cli process?

U can dial it back in your config.yaml; If you have to ask how, u probably shouldn’t be running this junk; To answer your question, its because the clones not having any nodes of their own try to turn all the users into full-nodes to get as many nodes as possible on the network. Certainly u can dial it back, but the default is BS.

The big problem is again the dormant nodes that don’t quit when you say “stop” these are largely virus-bots that take a life of their own, if not killed frequently. All of these chia-clones have this problem 100% even flax;

U need to write a bash script and say run daily that stop’s all, and kills all for every clone; Then start fresh; If you don’t do this then in time your system will become flooded with shit-bots. Your system will grind to a halt, and your db/sql mainnet database files will get hosed; This is why also you need to have your script do a daily ‘zip’ on the /db & /wallet/db, because they frequently get destroyed; Unless your run sqlite3 db ‘.test’ daily and get an ok you don’t know that your mainnet database files are hosed. Major problem with chia-net is they chose a toy database to do a man’s job; We don’t see these problems on bitcoin or ethereum.

The question begs to be asked “What were the chia-net dev’s thinking?” The answer is they weren’t;

The goal was never to have a professional secure stable long-term blockchain, the goal was always to help the HDD manufacturers boost their dying markets. Everybody was jealous of the GPU shortage and wanted to copy-cat and create fake shortages to 10x the price on all computer hw.

Already got a script, and no they don´t all call chia full node, its only the chia full node that runs 10x, every other is calling themselve “spare, flax Full node” sooo this can´t be. I don´t think that i got a virus, all checked all fine with live cd. If im closing everything, the ram frees up.
Ye shouldn´t run this junk of chia…
In windows it´s the same, 5-10x chia full node (original chia gui)

Nope, don’t do anything this guy says. It’s a plain lie, weak/baseless claims he can’t proof or anything.

They are scared to death that you might infect them with the redrum-fubar/somemoar-variant virus…