Attempted to update to 1.1.7 on Ubuntu and now its all screwed up, GIT seems to not pull new version

I went to update to new version 1.1.7 by following the instructions on INSTALL · Chia-Network/chia-blockchain Wiki · GitHub

After following instructions I still show version 1.1.5, which means when I did this for 1.1.6 it never worked I guess.

I saw someone say to delete your chia blockchain folder and reinstall. I have tried that, now when I try to . ./activate it says “bash: activate: no such file or directory”.

Can anyone give me some guidance on what I can do to correct this? I have tried using the install and update instructions and nothing is working. I really want o get back up and farming.

Thanks

Hi there, as 1.1.7 is not a branch name, it’s always named as a tag name. You can check with git pull command to see the exact branch names, I used git checkout batch_sql_1.1.6 instead. Anyways, when the official point the latest to 1.1.7, it will be easy to use a simple git clone command.

Here is my command lines for you, I also changed the configurations to install chiapos 1.0.3:

mkdir chia-blockchain

cd chia-blockchain

git init

git remote add origin https://github.com/Chia-Network/chia-blockchain.git

git pull

git checkout batch_sql_1.1.6

git fetch

git reset --hard FETCH_HEAD

sed -i ‘/chiapos==/c\ “chiapos”, # proof of space’ setup.py

chmod +x ./install.sh

sh install.sh

. ./activate

After install the latest version, please don’t forget to restart chia farmer with command: chia start farmer -r

Thank you for the information, I will try it out. Once I figure out how to get . ./activate to work again inside chia-blockchain

You’re welcome, you can just run . ./activate directly or source ~/chia-blockchain/activate to run in virtual environment.