Best way to update Swar Plot Manager Config while running?


I want to update the Swar Config and need to reload the manager, should I simply restart the process?
Last time I did, some Chia.exe processes were still running in the background, do I need to kill them as well? But that would corrupt my temp data.

Thanks for the support

Ctrl + c to exit swar view
python3 stop - stops swar
Edit your config file.
Python3 start

No need to kill any chia processes. Chia will still be running your previous plots, Swar should pick them back up when you restart it. Those previous plots will continue with the config they started with until they are finished, but any new plots after changing config & restarting swar will adhere to your changes made.


To speed things up, you can update the config.yaml before you do anything. It only references it on startup. The steps @hellegaard1 is one way. Or…

While everything is running
make your changes to the config then run
python restart

An issue I ran into earlier today. Check the debug log afterwards to make sure it didn’t throw an error. Because if the manager did not start, you won’t know until the next plot doesn’t start. The issue I ran into was caused by Powershell. Not sure why but it was throwing an error when I tried to start manager. I closed all my Powershell windows and tried again and it worked. Just a heads up.


When the edit of the config file is already saved, a restart should also be okay right?


Yes that should do it. No, wait. You need to call it with python.

1 Like

yes i understand that, but in your case you have to call Python3 restart while i have to call py restart, so i was referring to the syntax after the python call

I only started to use Python since last week, so it is all very new to me too :slight_smile:

1 Like

Then yes. It does the same thing as a stop then start. It just calls those two in one command. There is really no difference.


Thank you very much, I did as you instructed and it worked

Thank you for the update! I ran into a similar issue and reinstalling python fixed my issue. This time resarting went without a hitch

1 Like