BIOS hangs HBA SAS Expander

Hi guys,

I have one harvester, where I have 1 HBA card, going into 2 SAS expanders, which are connected to their dedicated power supplies that power SAS expander and the HDD’s.

I wanted to move Expanders to the main harvester PSU, but once SAS expanders are turned on together with the PC, bios hangs looking for all the possible drives to boot from indefinitely.

This prevents me from even rebooting PC after initially things are powered on in the correct sequence (PC first, then SAS expanders after), because at the reboot SAS expanders are already on, and boot hangs.

I know every bios is different, but what should I look at disabling in bios so I dont have this problem?
On the HBA card bios I tried disabling the bios mode and leaving only OS, but then I can’t see HDD’s anywhere … And I played with UEFI and and fast boot, and all the other available options, but to no avail.

Obviously the boot device priority is set properly …

Any ideas?
Mobo is Asus Prime X570-P AM4.

Try disabling option roms (optrom) for your pcie slots.

Do you have a boot order in your BIOS? On which device boots first?

Dont have an option to disable pice oprom.

First device is SATA SSD for the OS, connected to the motherboard sata controller.

Just asking, do you have a DVD on your system?

E17441_PRIME_X570-P_UM_v3_WEB.pdf ( if you dont have the manual.

No DVD, two nvme drives though.

But it doesent give that wrong boot device message, just hangs at the booth screen for ages.
Once Expanders are powered off, boots in a sec.

Thanks I’ve read the manual, but to no avail.

What the model type of the HBA card? Is this the IT-mode problem maybe?

People talking about the card needs to be flashed in IT-Mode…

FUJITSU d2607 9211-8i IT-mode p20 LSISAS 2008 SAS/SATA RAID SAS Controller Card

It’s in IT mode already.

Just a thought…on what others were talking about with some of these cards.

Whats the part number for the SAS expanders, just asking?

Is there an option in your HBA to stagger spin-up?

If it was working with separate power supply, maybe it’s drawing too much power on boot.

HPE 24 Bay 3Gb SAS Expander Card

Would I be better off getting the HP - 631670-B21-LP - HP SMART ARRAY P420/1GB FBWC CONTROLLER - WITH LOW PROFILE BRKT

rather then using Fujitsu with HPE?

Power is not the problem, problem is that bios all of a sudden has 48 hdd’s that are possibly boot drives, and tries to look through them all, which causes boot time to be horrendous.

Offcoure you would think that having a determined boot drive would prevent this, but this is really early stage of the BIOS, where it is only starting to recognize hard drives I believe, where it gets stuck.

1 Like

Did you disable “fast boot” in bios? Just asking.

I had a similar issue with HBA card. I reinstalled windows 10 from scratch after formatting boot ssd. The problem was solved.

No I haven’t disabled it, always thought that having fast boot on will help to skip just to the booth hard drive and not get stuck with anything else, but that obviously never worked.

I must of have done it in all the things I’ve tried, but I’ll try again.

Im on linux.

What drive are you trying to boot off? I remember having to set a delay for all of my disks becoming available before attempting to boot from a disk. I am booting from a sata ssd.

From one of the sata ssd’s directly connected to the Mobo.

How can I delay disks on HBA-Expanders??