Bloody hell... now its hanging at system start full node

Anyone any suggestions…please

1 Like

What version are you running and windows or linux?

1 Like

I once had a dirty shut-down. I thought that all Chia processes had exited, but they had not.

The result was that I had trouble starting up Chia on my full node, because of orphaned processes that I was not aware of.

I suggest that you re-boot your computer, and try again.

And if you are running Windows, do not use the “Power Off” option. Use only the “Restart” option.
The former writes parts of your current state to its hibernation file, and reads it back into memory upon powering up.

Whereas as restart clears out your memory, giving you a fresh boot.

So with a re-boot, you will have a fresh system, and no orphaned processes.
If, after a re-boot, starting Chia hangs, then a deeper dive will be in order.

You might need to re-install the software, or undo any config.yaml changes that you recently made.
By the way, which Chia version are you running?

1 Like

Many thanks for the replies…

I am running 1.5 on windows…

the only unusual thing was that I had the system shut down for 3 weeks to got on holiday…

I did a windows restart this morning, just before I set off for work, and started chia
hopefully when I get home it will be sorted

What does your “hung” state look like? It hasn’t started syncing? You won’t be farming for a few hours while it catches up

1 Like

It doesnt even get into the windows chia program

It is stuck a the loader screen
says… “starting services full node” on a black background with a “buffering “gif” type icon”

When was the last time you checked for windows updates, get that out of the way and also scan your machine just to be fresh.

1 Like

windows is fully up to date

Many an occasion with Chia i’ve had to do the following.

Stage one - create backups of the config and both database folders.
Stage two:

  1. Delete the config file and try chia - if it works you had a corrupted config
  2. Delete the wallet database and try chia - if it works you had a corrupted wallet database
  3. Delete the blockchain database and try chia - if it works you had a corrupted blockchain database

Still not working - go nuclear

  1. Backup database files, and config, and make sure you have your 24 words!
  2. Open file explorer type %localappdata% in the address bar and press enter, drill down to \AppData\Local\chia-blockchain\app-1.5.0\resources\app.asar.unpacked\daemon and then type CMD in the address bar and hit enter, then type chia keys delete_all and hit enter. Note app-1.5.0 will change when you install an updated version.
  3. Use add remove programs to remove Chia (not sure if this actually does anything)
  4. Delete the .chia and .chia_keys folder from the user profile folder
  5. Open file explorer type %localappdata% in the address bar and press enter - delete the chia-blockchain folder
  6. Navigate up one folder level, open the roaming folder, delete the Chia Blockchain folder
  7. For good measure reboot if you can.

I’ve had to do the above on many occasions to solve problems, then re-install, open Chia, enter keys, if it loads OK, close and restore appropriate backups - if it goes wrong again there’s a problem with one of the backups.

PS You’ll need to wait for everything to sync, wallet and blockchain, until that’s fully synced some things (Pool NFT’s/coins etc) may not show up.

1 Like

It maybe as simple as this;

Windows 10, blest then, does not necessary clear all the processes on a shut down / restart of your PC. Only a “restart” clears all current processes information. The restart option is worth a try. It has worked for me in the past.

Good luck, Pete

1 Like