Cant create K34 Plots anymore

i am currently plotting with my i9 12900k System with a WD Black AN1500 PCIe 4.0 NVMe SSD.
I was creating a K34 Plot in about 3.5 Hours (2.5 hours of plotting and about 1 hour for transfering the plot from my tmp drive to my HDD).
But since about 1 week or so the creation of my Plot keeps failing at about 50-60%.
I will post the Error which occurs in the Log File, in the next Post.
Do some of you have the same problem?
Do you know what i can try to fix this problem?
Do you guys plot with the Madmax Plotter itself, or with Madmax in the Chia GUI?
Im currently plotting with the Chia GUI cause i want to plot k34 plots.

I hope someone can help me!

By the way, is it possible to start a new plot with Madmax in the Chia GUI while the other plot is beeing copied to the final HDD drive?
I would plot a k34 plot within 2.5 hours, but the bottleneck is the 1 hour transfer time to the final drive.
I could shave of a lot of time, if i would be able to already start a new plot while transfering the other plot to the final drive.
Madmax Plotter (not Chia GUI) still only support k32 plots right?
K33,K34 is not possible yet?

If you go to:


There are two binaries there. chia_plot_k34.exe should plot k34 files.

By the way, I only plot with command line MM. The error you have up there is SSL related, so nothing really to do with the actual plotter.

Ok. But how can i set up the settings for the chia_plot_k34.exe?
Is there a way to actually disable the -w option so i can start another plot, while the other is beeing transfered at the same time?
What is the SSL Error? Maybe its because i use to much threads??

Btw. how to plot via command line like u said?
Can you help me? :slight_smile:

This is what I used for plotting chia with MM (note that I used the stotiks old version, not the latest provided by Chia):

SET TMP1=d:\chia\tmp\
SET TMP2=r:\chia\tmp\
SET XFR=d:\chia\xfr\


SET hr=%time:~0,2%
IF "%hr:~0,1%" equ " " set hr=0%hr:~1,1%
SET DATETIME=MadMax-Log__%date:~-4,4%%date:~-10,2%%date:~-7,2%_%hr%%time:~3,2%%time:~6,2%
IF NOT EXIST logs mkdir logs

if NOT EXIST %TMP1% ( mkdir %TMP1% )
if NOT EXIST %TMP2% ( mkdir %TMP2% )
if NOT EXIST %XFR%  ( mkdir %XFR% )

powershell ".\v0.1.6\chia_plot.exe -n %PLOTS% -r 25 -u 8 -v 8 -t %TMP1% -2 %TMP2% -d %XFR% -c %contract_addrs% -f %farmerkey% | tee '%LOG_FILE%'"

In that base folder, I only had that batch file to plot, and the other one to move those plots around. In the v0.1.6, I only had that one chia_plot…exe file. Nothing else related to Chia was on that box.

I have it in plotter.cmd file that is basically what was provided with that Win version. That d: drive was my NVMe, the r: drive was ImDisk RAM drive. The box is i9-10900 (non-K version) 10 phys cores (so it was overbooked), and was getting ~30 mins k32 plots.

I have never tried to plot k33 or k34, as I don’t have enough RAM for it, and don’t think that getting anything higher than k32 buys me anything.

So, again my k34 knowledge with MM is basically zilch, but I would assume that the same command line should do.

Basically, that is a nonsense that chia GUI doesn’t show the command line when selecting a plotter, so one can copy / past it, and be done with GUI.

@seymour.krelborn was dealing with that -w option. It is somewhere on this forum, so either you search for it, or he can chime in when he is available.

Also, when you specify something like -n 10, MM will sit in a loop and generate those 10 plots one after another without your intervention.

When you specify that your tmp1 is on the same drive as your dst folder (i.e., both on the same NVMe), there is no “copy” process there, as MM will just move the handle to point from tmp1 folder to dst folder (no byte transfer happens). That implies that whether -w option is wait for copy or not, it really doesn’t matter, as there is no physical copy of any bytes.

SSL is used to protect the communication channels between various chia modules (e.g., GUI and full node, or in this case plotter). No, it has nothing to do with your box being overtaxed, just bad code released by Chia.

1 Like

Ok thanks for the explanation there! :slight_smile:
So as far as i understand, the SSL Error should be gone right when i switch to the command line plotting?
I will definatly try it!
So the “only command” i need to type in powershell would be:

".\v0.1.6\chia_plot_k34.exe -n (Number of plots) -r (threads) -u (buckets) -v (buckets) -t (my nvme) -d (my hdd) -c (contract address) -f (farmer key)

this should start the k34 plotting process with the selected values then, right?

Thanks for the help! =)

By the way, what do you mean with my tmp drive is beeing the same drive as my destination drive?
How can i copy the finished files from my nvme to the hdd then automaticly?
It would shave of a lot of time for me if it would work

Yup, MM CMD line has no SSL code.

Kind of :slight_smile: Please note that I have that line in plot.cmd file, and in the folder that this file sits in I have a subfolder v0.1.6. The reason I have it like that, as at that time Max / Stotiks were having updates, and it was easier for me to keep those subfolders named like that, so eventually I could go back if something went South (never did), or I wanted to check something with the old plotter. If you put the plotter binary in the same folder as that batch file, there is no need to have that folder prefix there.

When your plot is finished, the final plot???.plot.tmp file is created in your TMP1 folder (your NVMe). When you specify your destination to be some HD, MM will start moving that tmp file to that destination HD.

On the other hand, when you specify that destination folder to be also on your NVMe, MM will instantaneously move that tmp file to the dst folder on the same NVMe, and will keep plotting. It will be your job to move that file off that NVMe, thus some sort of batch file will be needed. However, regardless of what that -w option will be, it will have no effect, as there will be no physical byte copying.

If you are not comfortable with that option, and you cannot get that -w flag sorted out (let’s say there is a bug there), another option would be to get a 2 TB SSD or NVMe, and use that for destination. This will give you about 10 plots worth of a buffer, so you would need to manually clean it up roughly once a day.

Don’t think I can help. But this is what you can do with Mad-Max plotter. My old HP Z440 is converted to a server type with 128Gig RAM, SAS extender driving 30 HDDs from 8tb to 18tb. Plotting time is 27mins and doing the transfer at the same as plotting [no waiting] is 7 to 10 mins included. I have always run MM in Linux Terminal. But I would think the the GUI would be ok. Best of luck with your problem.

Thanks for the help again!
So as i understand you create a folder (lets say i call it v0.1.6) and i copy the chia_plot_k34.exe in there.
And then i start the powershell from that folder with the settings we talked about before?

thanks for the advice mate!

If you go to that folder with your PS, you don’t need that folder prefix. You can just put there .\chia_plot_k34, and that should do.

Maybe the simplest thing to do would be to start PS, and check which folder it starts in (looks like it is in your \Users\YOUR_NAME), and just create a mm folder there. So, you could just start PS, change do ‘cd mm’ and run that PS line from there.

Although, you could also create mm.bat file, copy that PS line into that file, and also stick it into that mm folder.

Actually, that line is meant to be run from command line, not really PS, as you have the “powershell” invocation at the beginning of that line. You could strip that invocation and those double quotes (one at the very beginning, and the complimentary at the end). That would be a pure PS line. (I am not that PS fan, but CMD line doesn’t have tee, so that part sucks.)

Oh, what it also means that that “tee” at the end splits output to both the screen and to the log file (in my case). In your case, you don’t split it, so there is no need for that extra quote at the very beginning and at the end (it was there to let ps know what are the arguments to be used).

.\chia_plot_k34.exe -n (Number of plots) -r (threads) -u (buckets) -v (buckets) -t (my nvme) -d (my hdd) -c (contract address) -f (farmer key)

That should do.

Thanks! Will try it when im at home! =)

Yes, there was (might still be) a bug when using “chia.exe” to execute chia_plot_k34.exe

The command for doing so was:
chia plotters madmax … etc…

No matter whether you used “-w” or not, chia.exe would pass along “-w” to chia_plot_k34.exe, resulting in having to wait for the file copy before starting a new plot.

I had used “chia plotters madmax…” when I first ventured into using madmax.
I saw that “chia.exe” had built-in functionality for running madmax, and so I went down that road.

When I could not fix the “-w” problem, I started running “chia_plot_k34.exe” directly (and without the “-w” option). That worked, and madmax did not wait for file copies to complete before starting the next plot’s processing.

The above will start the “chia_plot_k34.exe” process, but it will not create a k34 plot (it will create a k32 plot).

chia_plot_k34.exe defaults to k32 plots.
You must use the “-k” option to specify an alternate “k” size (which would be “33” or “34”, as “34” is the largest size that madmax supports).

So add “-k 34” to your list of options on your command line.

1 Like

Ok if I add that -k option it should work?
If it really does it helped me a lot mate!!

Yes, it will work, if you supply the value for the “-k” option.

-k 33
-k 34
Whichever one fits your needs.

I have been plotting k34 with CLI and madmax as described above. I have a 1TB SSD for temp-1 and a 480GB RAM drive for temp-2. I can plot about 6.5 plots/day. I use HD Sentinel to monitor the health of the SSD and it drops 1% per day. This gives me about 600 k34 plots. In reality I got a few more plots than this, but then odd effects started to happen. The plots would complete but they had strange errors. Fitted a new SSD and all back to normal.

Thanks to every comment and for every help in this Thread.
Yesterday i tried plotting k34 Plots with the command line and it worked!
It even started the next plot, while transfering the “old” plot to the HDD.
I can create a k34 Plot in 150 Minutes now, which helped me reducing my plot time by a lot!
Thanks to everyone!
I think the “chia_plot_k34.exe” only works for k34 plots, i tried putting -k 32 in there, and it created a k32 plot as it should be, but my CPU usage was only at around 70% which puts the plotting time for one k32 plot to around 55minutes (with Chia GUI Madmax it takes me around 30mins).

Thanks for the help again! =)

1 Like

What do you mean that “chia_plot_k34.exe” only works for k34 plots, when you go on to say that you used “chia_plot_k34.exe” and created a k32 plot?

Also, CPU usage will vary, depending on where the processing is (which phase).
For example, phase 2, and especially phase 4, use less CPU cycles.

Also, your CPU could be waiting if, for example, your NVMe drive is a bottleneck.

Every computer has a bottleneck. When you remedy that bottleneck, then some other component becomes the bottleneck.

If your CPU is pinned at 100%, then your CPU is the bottleneck.

My k34 plotting does not always consume all of my computer’s resources (especially during phase 2 and phase 4).

So I run two at a time. Each plot does take more time. But the total time it takes to create two plots is less than if I created them one at a time.

With the Chia GUI Madmax my CPU Usage is 100% with 24 threads assigned.
With the k34.eye with -k 32 and 24 threads assigned my cpu usage is at around 50-70%.
Also plotting time is about 20 minutes longer with same settings and same hardware.
K34 stays the same, only k32 performs bad.
But as I mainly create k34 plots it’s totally fine for me :slight_smile: