Cant install downloaded database 2.0 on chia 1.5

Hi, i am trying to download the database of chia, but when i download and install it the full node in the GUI keep loading and never load, if i delete it i can download it from fresh database and all work fine, but it would take week to reach the actual height; i also try different database v2 web provider and all fails, is this a bug from chia 1.5.0 ? or all database are corrupted, or maybe i should wait in full node loading ??

1 Like

Bit the bullet and download from scratch the you will have your own know good database. Then make a backup after you shut down chia and copy it to two places, one on a USB harddrive second some drive d: or e: etc. It a learning process nothing comes easy.

1 Like

yes, i am trying but is so slow (i am at 1000000 approx in 1 week), i prefer taking the risk of downloading it; i am going to try a v1 database

I would not, what type of machine are you using CPU and memory and which OS?

1 Like

i7 7 gen, 24 ram, win 11, but cpu is at 4ghz underclocked
i have hight load CPU process so is probably that

So what else is running on that machine, you dont have a box for chia?

1 Like

some daemon process, gpu miner, etc

1 Like

To make it simpler your trying to install a fence and digging post holes with a coffee spoon. There’s only so much that box can do at once.

yes i know, that why i download the database, but is not working, going to try the v1

Then you have to do a db upgrade

see if you around the corner


Could copy to a USB drive

yea same files, there isnt a reliable web for database v2 to download

Hi Pachi
I had this same problem. I think somehow the database becomes corrupt during the download. Today I got the GUI to load. The error I was getting was a Malformed Database error. So tried to repair it. The first thing I did was open the database in an SQLite Browser. I used DB Browser on Fedora 36.

  1. The database is large so it will take a while to move from the first record to the last.

  2. I ran an integrity check on the database, which will take a while to complete.

  3. I did an export of the database, although I don’t think this is needed.

After it was completed used the command line to load the full node, I was surprised when it started. the big test, however, is chia dB validate. With that success, I can now open, and the sync status is 23886234/242403 still have 36 hrs before full sync.

I hope this helps

This is on Fedora 36 tonight I am attempting to move it to a Raspberry Pi 4 that I want to run everything on.

1 Like

thanks for the reply, where u downloaded the database? also it take long time to the full node to start? and db validate found errors or orphan blocks ? also i am no windows, not sure which software use to repare it

I downloaded it from https://chia.sponix.net/

DB Browser has a Windows install.
https://sqlitebrowser.org/dl/

the integrity check is in the tools menu.

thanks, going to try, is required a chia db validate too ?

The db validates and reads the complete blockchain, so if it is successful it’s a good chance the GUI will open…