Can't reach port 8444 from the WAN (part two)

So, last time I have shown you my network setup. (Can't get port 8444 open on Ubuntu Linux) It’s an Asus router under a poe/antenna router that is connected to the internet, and since I couldn’t open port 8444 and forward it to my Ubuntu plotting rig we thought that the problem was the external poe/antenna not forwarding requests to the Asus router.

Now I’ve chatted with my ISP and they set up a DMZ from my antenna to my internal router, so that every freaking requests it receives, gets forwarded to the internal asus router.

Is 8444 finally open to the WAN? Nope. Only LAN.

So I started looking around in the Chia’s config.yaml and found out that all the fields that go by “host” are configured to “localhost”

Since I can connect to port 8444 from the LAN but not from WAN, I am starting to think that Chia is not configured properly and open to the network. Is that okay?


(port is still closed with UPnP disabled)

And also all the other various “host” fields are set to localhost

Checked my config and its the same as yours. Getting 50 peers in the connected list. How are you checking that 8444 isn’t available from the WAN?

1 Like

Simply using this web tool: Open Port Check Tool - Test Port Forwarding on Your Router
Or running:
Test-NetConnection MYIP -p 8444
In the Windows Powershell from a different machine that isn’t the plotting machine.

By the way, under “Full node” tab I am getting 1 farmer (me) 1 worker (me) and 4 full nodes

Is this normal?

Ah ok.

Yeah, that isn’t normal. You should get 50 peers if you’re networking is setup correctly. Let me read your other post.


I noticed in your other post that you have port forwarding to 8447 and 8449? You do not need to do this. Just port 8444.

Can you log into your antenna router? Usually the ISP routers have a way to log in to manage forwarding rules as well.


I removed those forwardings, I’ve read to add them somewhere on GitHub from an user but honestly the only official one is 8444.

Anyways, no I can’t manage myself the antenna, I need to speak with them.

They tried first with a DMZ forwarding all requests to my internal router and it didn’t work

Then they tried with a simple 8444 forward to my router and it isn’t working either

That’s why I am starting to think that all those “localhost” in config are suspicious. Shouldn’t there be at least a “” standing for my external ip?

Your router should have a WAN IP. Can you use that port checking website to see if 8444 is open on the router? If not, then the antenna router isn’t forwarding correctly.

1 Like

My ASUS router has an IP assigned by the antenna, but it’s a local IP and I can’t reach it from the outside of my network. So of course, it says it’s closed.

If I try to ping that IP on port 8444 from within my network, I get redirected to another IP, it’s weird. The IP i get redirected to can’t be reached tho.

If you want to know my current setup on the asus router:

  • Ubuntu box has a static IP since I assigned that ip to it’s mac address on the router
  • DMZ disabled
  • Port 8444 forwarded to ubuntu box
  • Port triggering disabled
  • NAT enabled
  • NAT set to open, with forwarding of port 8444 to my ubuntu box
  • NAT Passthrough enabled
  • UPnP enabled

If I enable DMZ nothing changes

Oh, I thought you said that the antenna router put your asus router in the DMZ. That’s why I thought it would show up as Open.

With UPnP enabled, you shouldn’t need to mess around with all this port forwarding. Did you disable the UPnP setting in the yaml.config?

Nope. The ubuntu box is the only machine in my house with UPnP enabled in config.yaml, all the other machines are set to false on upnp and aren’t even port forwarded. The only machine with upnp on (and also port forwarding) is the ubuntu box.

And yeah, disabling port forwarding keeping upnp on, do not solve the issue :frowning:

I think you’ll need to start troubleshooting piece by piece. I would plug a computer straight into the antenna router and make sure that ports are open there.Then proceed with the asus router. Place a computer into the DMZ on the asus router and make sure that the computer ports are open. Then figure out what asus settings are blocking the ports from being open.

1 Like

Don’t tell me how but at the end I managed to crank it open and I am not connected to lots of peers lol

For the other machines in my home what am I supposed to do? I move all the plots by hand every 1/2 days to my main ubuntu rig since eventually I will start farming just on that one, but as of now? Can they be synced too or only one machine at a time can be port forwarded and correctly synced?

Great news! The peers should trickle in slowly.

How many other machines do you have? Do you have the GUI up on more than one machine on the same network? This will also cause sync issues. You can run them in harvester mode. Just be careful about farming times. They shouldn’t exceed 30 seconds.

1 Like

Yes I have another two machines running on the same network, both have UPnP disabled since I’ve read that it creates problems if more than one machine use it at the same time. But they all use the GUI! Is that a problem?

What do you mean for run them in harvester mode and the note about farming times? I use them to plot as well, the plots stay in the machines for a day or two and then I manually move them to the main plotting/farming (all in one) machine, the one I port forwarded :slight_smile: