Can't Setup Harvester on 2nd Machine


I tried to setup another harvester on Win 10 and replicated the exact steps as in the video of NotAnotherTechChannel on Youtube. I can’t add more space to main plotter and want to plot remaining HDD’s on main plotter and then farm them on 2nd Machine.

However, two things were different.

1).\chia.exe plots check → produced this error message
‘…has a farmer public key that is not in the farmer’s pk list.’
‘…has a pool public key that is not in the farmer’s pool pk list.’

  • For context: I did join core-pool, did it mess with the config.yaml and produces the pool public key error?

2).\chia.exe start harvester → produced this error message
‘PS C:\users\de\AppData\Local\chia-blockchain\app-1.2.2\resources\app.asar.unpacked\daemon> .\chia.exe start harvester
Daemon not started yet
Starting daemon
chia_harvester: started
PS C:\users\de\AppData\Local\chia-blockchain\app-1.2.2\resources\app.asar.unpacked\daemon> Traceback (most recent call last):
File “D:\a\chia-blockchain\chia-blockchain\venv\Lib\site-packages\chia\server\”, line 57, in
File “D:\a\chia-blockchain\chia-blockchain\venv\Lib\site-packages\chia\server\”, line 53, in main
File “chia\server\”, line 255, in run_service
File “asyncio\”, line 44, in run
File “asyncio\”, line 642, in run_until_complete
File “chia\server\”, line 249, in async_run_service
File “chia\server\”, line 170, in run
ValueError: harvester: already running
[684] Failed to execute script start_harvester’

  • For context: I already added one full HDD with Chia plots on 2nd machine under ‘D:Chia Plot’.
    There is no other folder, hence I don’t understand the ‘…D:\a\chia-blockchain…’ reference.
    Also, the chia-blockchain files on main plotter are on C: and not D:

Do I have to insert mnemonic seed phrase on 2nd machine to resolve this issue?

Any help is appreciated. Thank you :slight_smile:

Use this official guide step by step: Farming on many machines · Chia-Network/chia-blockchain Wiki · GitHub

The warning about keys in chia plots check doesn’t matter for harvester.

You do not need to initialize full node with mnemonic. In fact, you don’t even need to touch chia gui.

Thanks for your input. I’ve done exactly that, but it won’t work.
Perhaps, disabling UPnP will help?

I’m presuming you are using Windows. Learn how to view chia debug log through powershell.

Have at least 1 plot on the harvester machine and configure chia to scan that directory of plots (all is done in CLI, you don’t need to run the GUI). Also change configuration to make debug log level = INFO

Once started harvester, make sure the command line window where you ran the command stays open, because closing it will terminate the harvester.

While it is running, you should be able to see debug log entries once in a few seconds that it scanned 1 plot. At the same time on the main farmer node, if you run GUI, in the farm tab, click advanced options and it should show your harvester node on the network (besides

do you copy the CA folder from Farm machine to Harvester and run the " init CA " command ?

1 Like

This error is due to not having your mnemonic entered in the harvester, the init from the copied ca folder does not include your public keys, it just creates a compatible ssl certificate to securely communicate with your farmer. I added my mnemonic to my harvester plotter specifically to run plots check, but it is not required for proper harvesting.

Thanks again. I will try that and see if that works.

Yes, I followed the exact steps as instructed by Farming on many machines · Chia-Network/chia-blockchain Wiki · GitHub.

Thanks for your feedback. I can’t figure out the solution to my specific issue.