Can't start farmer from CLI

GUI seems to work fine, but when I try to do from CLI I get this:

PS C:\Windows\system32> cd C:\Users\111\AppData\Local\chia-blockchain\app-1.2.0\resources\app.asar.unpacked\daemon
PS C:\Users\111\AppData\Local\chia-blockchain\app-1.2.0\resources\app.asar.unpacked\daemon> .\chia.exe start -r farmer
Daemon not started yet
Starting daemon
Traceback (most recent call last):
File “D:\a\chia-blockchain\chia-blockchain\venv\Lib\site-packages\chia\cmds\”, line 83, in
File “D:\a\chia-blockchain\chia-blockchain\venv\Lib\site-packages\chia\cmds\”, line 79, in main
File “click\”, line 829, in call
File “click\”, line 782, in main
File “click\”, line 1259, in invoke
File “click\”, line 1066, in invoke
File “click\”, line 610, in invoke
File “click\”, line 21, in new_func
File “D:\a\chia-blockchain\chia-blockchain\venv\Lib\site-packages\chia\cmds\”, line 61, in run_daemon_cmd
File “asyncio\”, line 642, in run_until_complete
File “chia\daemon\”, line 1005, in async_run_daemon
File “chia\daemon\”, line 128, in init
File “chia\server\”, line 34, in ssl_context_for_server
File “”, line 791, in _create_unverified_context
FileNotFoundError: [Errno 2] No such file or directory
[14228] Failed to execute script chia
Daemon not started yet
Failed to create the chia daemon

Can someone tell me what am I doing wrong? :roll_eyes:


I do not understand the structure. Why are two hard drives displayed? C:\ and D:?

I have no idea :smiley:

D:\ is just one of my hdds, I ran chia start node/farmer from my Chia folder, why is it talking to D:…

ah. and now I can’t even start my GUI after trying to launch farmer from CLI

2021-07-10T21:52:54.399 full_node chia.full_node.full_node: ERROR Exception in create outbound connections: [Errno 2] No such file or directory
2021-07-10T21:52:54.400 full_node chia.full_node.full_node: ERROR Traceback: Traceback (most recent call last):
File “chia\server\”, line 233, in start_client_async
File “chia\server\”, line 339, in start_client
File “chia\server\”, line 54, in ssl_context_for_client
File “”, line 791, in _create_unverified_context
FileNotFoundError: [Errno 2] No such file or directory

what this all means? :expressionless:

Usually only the first or last message is important: File or directory not found. I recommend uninstalling chia, checking the folders to see if they are empty. Then reinstall.

Under no circumstances should you grab the “.chia” folder in the user folder, your private keys are there.

1 Like

Did you

Chia init ( needed in cli )

Since you updated?

Not sure why gui wouldn’t load.

yeah, I tried everything :expressionless: had to delete Chia software and start from scratch.

it is still very raw, so I guess we gonna see a lot of minor bugs…

Loads of ppl getting warnings and super bad response times.
I’m waiting till its sorted.