Can't sync after updating to 1.2.0

I was solo farming with 1.1.7 via docker on a Synology NAS just fine for a few weeks. I then updated to use the latest docker image (which is pointed to the 1.2.0 tag on GitHub).

I started to get timeout errors and other strange things in the logs regarding the wallet, so I deleted wallet/db and restarted the docker container.

Port 8444 is forwarded to this machine on my router.

Now I seem to have 2 issues, but I think they may be related. First is this issue that appears over and over again in the logs:

2021-07-11T21:23:31.501 full_node chia.full_node.full_node: INFO     peer disconnected {'host': '', 'port': 8449}
2021-07-11T21:23:31.503 wallet chia.wallet.wallet_node    : ERROR    Loop exception in sync Was not able to add blocks 0-32. Traceback (most recent call last):
  File "/chia-blockchain/chia/wallet/", line 581, in sync_job
    await self._sync()
  File "/chia-blockchain/chia/wallet/", line 661, in _sync
    await self.batch_sync_to_peak(fork_height, peak)
  File "/chia-blockchain/chia/wallet/", line 538, in batch_sync_to_peak
    raise RuntimeError(f"Was not able to add blocks {start_height}-{end_height}")
RuntimeError: Was not able to add blocks 0-32

2021-07-11T21:23:31.505 wallet chia.wallet.wallet_node    : INFO     Loop end in sync job
2021-07-11T21:23:31.506 wallet chia.wallet.wallet_node    : INFO     Loop start in sync job
2021-07-11T21:23:31.528 wallet wallet                     : INFO     Reconnecting to peer {'host': '', 'port': 8444}
2021-07-11T21:23:31.779 wallet wallet_server              : INFO     Connected with full_node {'host': '', 'port': 8444}
2021-07-11T21:23:43.489 wallet chia.full_node.weight_proof: INFO     validating 1439 sub epochs
2021-07-11T21:23:43.504 wallet chia.wallet.wallet_node    : INFO     Validated, fork point is 0
2021-07-11T21:23:43.506 wallet chia.wallet.wallet_node    : INFO     self.sync_event.set()
2021-07-11T21:23:43.556 wallet chia.wallet.wallet_node    : INFO     Have collected 3 potential peaks
2021-07-11T21:23:43.559 wallet chia.wallet.wallet_node    : INFO     Requesting blocks 0-32

The other issue I noticed is that running chia show -s -c sits and waits for a while (~10m?) and then times out with this error:

<some remote ip> asyncio.exceptions.TimeoutError

Am I just connected to a bad full node? Anything else I should do to troubleshoot?

Still not sure what happened, but I decided it was probably just best to nuke my db and wallet/db folders and start over.

I ran chia stop all -d, deleted the above folders, and then restarted the docker container. Everything in the logs looking normal now and running chia show -s -c no longer hangs.

Looking like it will take ~48h to sync up fully, but I can live with that.