Chia 1.6.1 install errors ubuntu 22.04 missing dependencies (solve)

What up with this new install?

I reinstalled 1.6.0 and I backup

sudo apt install ./chia-blockchain_1.6.1_arm64.deb
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Note, selecting ‘chia-blockchain:arm64’ instead of ‘./chia-blockchain_1.6.1_arm64.deb’
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
chia-blockchain:arm64 : Depends: libgtk-3-0:arm64 but it is not installable
Depends: libnotify4:arm64 but it is not installable
Depends: libnss3:arm64 but it is not installable
Depends: libxss1:arm64 but it is not installable
Depends: libxtst6:arm64 but it is not installable
Depends: libatspi2.0-0:arm64 but it is not installable
Depends: libuuid1:arm64 but it is not installable
Depends: libsecret-1-0:arm64 but it is not installable
Recommends: libappindicator3-1:arm64 but it is not installable
E: Unable to correct problems, you have held broken packages.

Every update comes with bugs because of the lack of beta testing.

3 Likes

You got that right, Thats why we had test groups in software company’s

3 Likes

Do you really mean to be using the ARM64 package? Are you on a Raspberry Pi? If not, get the x86_64 package.

Or you might just need to do an apt-get update first.

3 Likes

It looks like my mistake. Thanks for finding it. I miss it arm amd look about the same in the CLI

Also I do a update and upgrade weekly.

thanks again

2 Likes