Chia daemon refuse to start (Waiting Daemon WebSocketServer closure)

Hello All,

I am running chia full node+harvester+wallet on Arch Linux. Today I made mistake by updating system without prior shutting down chia services. After system update I wasn’t able to normally shutdown chia services because I got message about some broken python dependencies in chia-blockchain folder. I just restarted operating system hoping that this will help. After restart I still wasn’t able to run chia farmer services (broken python dependencies in chia-blockchain directory). I deleted chia-blockchain folder, downloaded it again following installation instructions from chia-git website. Issues related to python disappeared but from now every time when I try to execute chia start farmer command I get information that chia daemon can’t start (but I see 4 instances are running when I check system processes).
[Outputs marked as red 1 and 2 on attached screen.]

I set log level to DEBUG but it outputs only 2 lines (when executing chia start farmer) without any detailed informations.
[Output marked as red 3 on attached screen]

When I try to run daemon alone (by executing chia run_daemon command) it stucks displaying:
[Output marked as red 4 on attached screen]

But in logs I can see the same message as after executing chia start farmer:
[Output marked as red 5 on attached screen]

As a new user I can only upload one picture this is why I had to combine all outputs into one picture.

What can be wrong? I would be gratefull for your support.

Did you reboot after reinstalling?

Yes, of course, many times.

This is pretty strange. Folder .chia is only holding data and deleting and reinstalling chia-blockchain folder is done often by people (installing new versions instead of upgrading the client) without issues.

Maybe backup your db and wallet folders (after reboot), delete .chia folder and start all new. When this works you can stop, reboot, restore db and wallet folders.
In two steps, first restore db and see if it starts syncing.Wallet should sync from zero.
Second restore your wallet folder (after stopping also).
No idea what happened but most likely the db and/or wallet got corrupted (my guess).

(Of course you have to also set up plotting directories in config.yaml and other changes you made manually)

1 Like

Thank you for your response. I tried removing chia_blockchain and .chia folder and installing it again according to chia git FAQ but still the same error. Today I did fresh installation of operating system (I thought that maybe something broke up during unfortunate update) and still the same problem…
I have started to think that current chia client is not compatible with some new packages version in my Linux distro repo (for example Python in version 3.10.1-2)… The worst thing is that the log doesn’t help at all and I do not know Python at the level that would allow me to debug chia client app by myself. :confused:

I don’t know your setup/machine, but if it has sufficient specs and you want to stick with arch (don’t know it myself) you could install some hypervisor (e.g. virtualbox) with a ubuntu vm for a full node.
Either passthrough the plot hdd’s or you could try if chia client will start as harvester only on arch and configure a farmer/remote harvester setup. With both VM and your system on same subnet this should work just fine over the hypervisors bridge network.

Or maybe this is just a stupid idea… :wink:

1 Like

Maybe that is a related issue, as it also happened on archlinux (install boost asio or rather downgrade Python to 3.9):

1 Like

Thank you for your suggestions, they are good. I would do something like you proposed if I wasn’t able to find any solution for longer period of time (I am solo miner so up time is one of the most important metrics for me). Fortunately I think that I solved the issue - it was related to Python version 3.10! So I warn you all do not update Python to version 3.10 and stay with 3.9 at last until next relase of chia installer!

Instructions for other Arch/Manjaro Linux users who encountered this problem.

  1. Downgrade Python to version 3.9 by doing following steps:
  1. Delete chia_blockchain directory (after python downgrade current chia installation will be broken).

  2. Follow installation steps from chia git FAQ but before executing ‘sh’ edit ‘’ file and comment line:
    #sudo pacman -S --needed python git’.

  3. You can also add python to pacman ignored packages list to prevent automatic update of python package during system update. To do this you have to edit ‘/etc/pacman.conf’ file, find line
    #IgnorePkg =’
    then uncomment it and add python to the list:
    ‘IgnorePkg = python’

After applying mentioned steps I am again able to run chia services. Big thanks to kiwihaitch user from Chia Keybase support list who suggested me to downgrade python version.

Jacek thank you for your response. Yes indeed it was Python. (:

1 Like

Great, happy farming :grinning:

1 Like