Chia Keyring ... where is it?

You would think that deleting the .chia and .chia_keys folder would leave you with a blank slate.
But after doing so and I run chia init, it is still using a previous key for default payouts. What I’m expecting it to say is “No keys present, use chia keys generate”… as it does when you first install chia for the first time.
So where is this key being stored if not inside .chia or chia_keys? Is it in an environment variable or something?

When you deleted both folders .chia and .chia_keys did you reboot the machine?

With windows os, i believe theyre stored elsewhere, unfortunately im not sure where that is though

no its not a machine I can just easily reboot; its running things 24/7

hey thanks for reply im on linux

Current versions do store the keys under ~/.chia_keys however earlier versions used python_keyring under ~/.local/share. I think it moved around v1.2.6.

If you have the python keyring directory that is probably where they keys are, but before deleting it be careful that no other apps are storing keys there.

1 Like

Presuming you now have Chia installed again just run the following commnad - make sure you have your 24 words.

chia keys delete_all

Just for completeness, in case somebody on Windows wants to know how to completely remove Chia this is what I do.

  1. Backup database files, and config, and make sure you have your 24 words!
  2. Run chia keys delete_all
  3. Use add remove programs to remove Chia (not sure if this actually does anything
  4. Delete the .chia and .chia_keys folder from the user profile folder
  5. Open file explorer type %localappdata% in the address bar and press enter - delete the chia-blockchain folder
  6. Navigate up one folder level, open the roaming folder, delete the Chia Blockchain folder

That normally gets completely rid of it on Windows.

I’ve had to do the above on many occasions to solve problems, then re-install and restore appropriate backups.

1 Like

Indeed, the mystery is solved. Version 1.5 was still pulling keys from python keyring inside .local/share since I had used a previous version prior that was using it. I got rid of the python keyring file and chia now operates with a clean slate.

1 Like