Chia not receiving new challenges after db move

I followed the guide at
How to move the Chia db to another folder [ Wiki] to move my db to an ssd.

I am on ubuntu.

Seems like I am able to sync and everything is connected fine, however I am not able to farm any plots despite the status page saying farming. It seems the farmer is not connected as there is no connections under “your full node connections”. I have tried looking through forums and many different sources to no avail.

Please help.

Is it showing the plot count correctly?

Are you on Flexpool? Just run FlexFarmer to farm you don’t need a synced node.

Also I had this bug before I deleted the db and resynced to fix it.

Yes everything seems to be normal including the plots. The only thing different from when it worked is the screenshot shown. No last attempted proofs, no latest block challenges and no full node connections.

I am not in flexpool. I considered deleting db, but I remember it takes days to redownload. I heard there was a way to download quicker but don’t know where to find it.

Yeah you can download a recent sync and put it in the folder but obviously there are security risks to that.

Would strongly suggest switching to Flex given that their software solves this problem somewhat plus its completely optional.

There are places online that say they have the db, no idea if this is a virus or not user beware

Thanks but I think thats not an option as I have old plots not compatible with pools.
Maybe I will just redownload the entire db.

Thanks for everyones help.

Ok figured it out. I guess I’m an idiot. Hopefully helps someone. My config.yaml was missing some words:

It should be

host: localhost
port: 8444

but mine was

host: localhost
port: 8444

I must’ve accidentally deleted some words while changing the database path. Lesson is to check the config.yaml carefully.


valuable lesson :wink:
I always make a copy of the file before editing it…

1 Like