Chia’s official DB download to get synced Faster

For those trying to get synced faster and safely,

Chia now has an official DB download via BitTorrent.

6 Likes

Of course they FINALLY do this after I FINALLY got synced (took appx. 3 WEEKS).

But at least it’s now here for future new folks.

Nice to see they listened - eventually.

5 Likes

Jaysus… Why did this take so long… It’s not like they did t have bit torrent as a tool from the beginning

1 Like

Iirc, torrents werent considered safe.

I think that the current scams pressured them to do something…

1 Like

Hi,
downloaded the torrent, verified the signature, extracted to the chia db folder, stopped the chia service, backed up old db, renamed downloaded and started:

Completed startup.  Browse to port 8926.
Traceback (most recent call last):
  File "/chia-blockchain/venv/bin/chia_full_node", line 8, in <module>
    sys.exit(main())
  File "/chia-blockchain/chia/server/start_full_node.py", line 97, in main
    return async_run(coro=async_main(service_config), connection_limit=target_peer_count)
  File "/chia-blockchain/chia/server/start_service.py", line 278, in async_run
    return asyncio.run(coro)
  File "/usr/lib/python3.10/asyncio/runners.py", line 44, in run
    return loop.run_until_complete(main)
  File "/usr/lib/python3.10/asyncio/base_events.py", line 646, in run_until_complete
    return future.result()
  File "/chia-blockchain/chia/server/start_full_node.py", line 80, in async_main
    await service.run()
  File "/chia-blockchain/chia/server/start_service.py", line 179, in run
    await self.start()
  File "/chia-blockchain/chia/server/start_service.py", line 144, in start
    await self._node._start()
  File "/chia-blockchain/chia/full_node/full_node.py", line 402, in _start
    num_unspent = await self.coin_store.num_unspent()
  File "/chia-blockchain/chia/full_node/coin_store.py", line 93, in num_unspent
    async with conn.execute("SELECT COUNT(*) FROM coin_record WHERE spent_index=0") as cursor:
  File "/chia-blockchain/venv/lib/python3.10/site-packages/aiosqlite/context.py", line 41, in __aenter__
    self._obj = await self._coro
  File "/chia-blockchain/venv/lib/python3.10/site-packages/aiosqlite/core.py", line 184, in execute
    cursor = await self._execute(self._conn.execute, sql, parameters)
  File "/chia-blockchain/venv/lib/python3.10/site-packages/aiosqlite/core.py", line 129, in _execute
    return await future
  File "/chia-blockchain/venv/lib/python3.10/site-packages/aiosqlite/core.py", line 102, in run
    result = function()
**sqlite3.DatabaseError: database disk image is malformed**

Anyone with the same error?

What a lame excuse to (maybe if it works) solve a long standing issue that they should do w/better programming of the db. Just saying.

1 Like

Have to change the main farmer computer. Old one (2+ years) was to weak for compressed plot.

Can I just copy out the db from older farmer to the new farmer?

Yes, just make sure Chia is fully closed down, and both are on the same DB v, preferably version 2.

My chia wont sync so i deleted all in db folder and downloaded blockchain from torent and put it in db folder but its syncing from 0? why is that?what im doing wrong?

After extracting, did you cut the date out of the file name? I missed that too last time - it has to match the old database file name exactly.

yea, i forgot that. thanks

1 Like

So i downloaded and synced 100% and status in not synced… anyone know solution?

I got that when i moved to 2.0.
Ive yet to troubleshoot, i will tomorrow, had to blow the dust bunnies out first.
Ive got to port forward yet, but it should work without it.
Tried deleting peers file to get new ones?