Difficulty importing private key 24 word mnemonic


Have node on Win, but want to move it to ubuntu. Have stuck on importing wallet words. Can’t find the correct syntax.

Trying this:

chia keys add
Enter the mnemonic you want to use: 24
Invalid mnemonic length
No keys are present in the keychain. Generate them with ‘chia keys generate’
(venv) amd@amd:~/chia-blockchain$

Also tried just tu put all words, but it did not worked out as well.

Is there any step by step chia guide for ubuntu cli?



With 20 characters :slight_smile:

here you have to enter your 24 words. Works perfectly - done a thousend times.

1 Like

Strange… :expressionless: I did that and it did not went through…

Is there any syntax for words? Like:

word1, word2, word3,
word1; word2; word3;
word1 word2 word3

tried this. But did not worked. Maybe mistyped something?

1 Like

I believe it was my mistype mistake.
Thank @Flofi you for your help :slight_smile:

So the correct answer is to use spaces?

Yes. Correct. Only spaces.

In the case you mistype, the error does not tell you that. It just gives the same error as nothing inputted.

1 Like

I failed at that too, until I copied the output into a txt-file and used that for import with param -c i guess.