Drive appears empty after restart

So… I have a fully plotted 12tb WD external drive. I spent a good amount of time plotting it out completely and now it appears empty. Check disk reveals no damage, and it otherwise functions fine. What could have happened?!

To provide some more info, I’m on Ubuntu 20.04. When I open properties on the disk it says that almost all 12tb are use (which is a nice sign), but under Contents it says “nothing.” I can’t find any discussion about trying to recover data hidden or lost in this way that doesn’t have to do with people trying to free up disk space.

weird…it might be a user permission issue or something like that. hope someone has a better guess than me.


My guess is… maybe you accidentally moved all your plots to a hidden directory?

Run ls -al to check.

1 Like

Try to open the drive from another pc (or laptop) and change the drive letter.

1 Like

@ksevin Thanks. Yes, opening it on another computer I can see all the plots. I’ll consider just farming from there in the short term.

I also tried restarting the system with the drive disconnected to change the drive letter but I have the same problem of files not appearing on my Ubuntu system. It’s very strange.

I had a similar situation and solved the problem. Go to devices in windows. From menu make a setting to show hidden devices. Probably there you will see the hard drive device as grayed (faint font). Windows creates a cache of previously opened devices. So if you delete the device and then connect it, windows will see that as a new device. That worked for me.