Drive response times high - 8TB Intenso external hard drive

Fellow farmers - advice/suggestions welcome!

So I’ve had a few issues with the farm - managed to localise it to one particular external USB drive

Its a 8TB Intenso hard drive - USB 3.0. Not a make/model I’m otherwise familiar with

Responses are consistently 20-40 seconds in marked contrast to all my other drives (inc approx 40 external USB drives). Windows 10.

I’ve tried it on a few machines and it is a consistent issue.
Definitely plugged in USB 3.0 ports.
Have changed USB 3.0 cable to no effect
Have ensured drive doesn’t sleep in device manager
Write caching enabled on drive

Wondering if I should shuck the drive & try on direct SATA 3 port but keen to try any other ideas anyone may have!?

What diag have you run on this drive? What speed is the drive? Easy check with

image just to simple test.

1 Like

Also what does CrystalDisk tell you about the drive?

1 Like Intenso 3.5 Memory Center 8TB USB 3.0 (Black/Black) : Electronics

Then below is stated the interface is USB 1.1 which is 12mbps


Man, that sucks. It literally says “UBS 3.0” all over the box & literature

You saw the screen from Amazon info… Need to find some software test tool for USB transfer etc. Maybe put it into another USB 3.0 case and test it.

Try this writing every 30 seconds : GitHub - stsrki/KeepAliveHD: Prevent hard-drives from going into sleep mode.

Thats if the drive is going into standby, Now if this drive really has a USB interface 1.1 its like trying to fill a swimming pool with a straw size hose…

I farm with usb 2 with no problem, what would the problem be with usb1? the ressources required are very small. I would return the drive if it takes too much time to diagnose but still worth a try

USB 1.1 is 12 mbps, USB 2.0 is 480 mbps, USB 3.0 is 5gbps

that’s 1.5mb/s i don’t see how that’s the problem

Do you know what happens when you plug 1 slow USB device into a HUB, the HUB runs all ports at that slow speed.


Copy 1 plot over a USB 1.1 connection and tell me how many beers you could have. :crazy_face: :crazy_face: :crazy_face:


Thanks everyone, I will test the drive this evening if I have time - I don’t notice the copy over to be excessive but it was scripted so wasn’t watching it too closely.

I would have thought the data transferred for lookups wouldn’t have been excessive for even USB 1.1

So an update - transfer speeds look good 90MB/s

I’ve tried KeepAliveHD which seems to have “fixed” the problem - no more long responses. Suggests the drive is “sleeping” but I’ve turned that off in Windows devices (specific drive & all USB ports).

Still keen to understand why it is sleeping though. Might it be a firmware issue what that drive? (all drivers up to date)

1 Like

Some drives ignore those settings and the drive forces it anyway, at least I’ve read that happens.

1 Like

I’ve never been able to keep my disks spinning without using a script, it’s a very common problem. Glad it fixed your issue!

If your running Windows, check your power options
Also check your device manager. Universal Serial Bus controller settings (each one) for Power management to be unchecked image

If your running Linux, your have to look more.

1 Like

That’s what I do, I’ve never run a script for this.

1 Like

Do what works for you!