Error using prover object badbit or failbit after reading size 2 at position

Hi All,

This is driving me insane.

I can run chia for several hours with no problems, then all of a sudden i get a log of these errors and bad look up times.
I am using external USB hard drives either connected via a USB hub or directly into PC. Is anyone else having these problems?

Here is what i see in my log.

2021-10-02T02:53:05.391 harvester chia.harvester.harvester: ERROR Error using prover object badbit or failbit after reading size 4 at position 107545566652
2021-10-02T02:53:05.391 harvester chia.harvester.harvester: ERROR Error using prover object badbit or failbit after reading size 2 at position 108569792222
2021-10-02T02:53:05.392 harvester chia.harvester.harvester: ERROR File: K:\Plot 6 NFT\plot-k32-2021-09-27-02-44-27accf7ea66164f84106637bc589e6cb522e7608ea8a85e7606018ea0463333f.plot Plot ID: 27accf7ea66164f84106637bc589e6cb522e7608ea8a85e7606018ea0463333f, challenge: eed7223b3f1a2b547535d0853eb2a699fba384682c76050dc088152d66d3b92c, plot_info: PlotInfo(prover=<chiapos.DiskProver object at 0x00000223287051B0>, pool_public_key=None, pool_contract_puzzle_hash=<bytes32: 72682d95ce0c58ac2f897832e86aa42ab6431d7b87b18bb8773e63f7813583dc>, plot_public_key=<G1Element 99e2ae3fee21f1bbc762b44f828fea0bb1de3243f326d5c252f26ea13877a16dc5819c1cf1e786dd4201b300aa0cdc8e>, file_size=108834139772, time_modified=1632709444.4857774)
2021-10-02T02:53:05.392 harvester chia.harvester.harvester: ERROR File: S:\Plot 11 16tb\plot-k32-2021-06-27-17-49-b9686b373ddff27d52a48b0aaf436ad6df7c207c2ac8886b35905e2a481d1c06.plot Plot ID: b9686b373ddff27d52a48b0aaf436ad6df7c207c2ac8886b35905e2a481d1c06, challenge: cb4826fe2b7977b6ec2fe3ab5e523d89491997347dd1851c70ea5f750b12e35a, plot_info: PlotInfo(prover=<chiapos.DiskProver object at 0x00000223270715B0>, pool_public_key=<G1Element 896acfdab07f4394cc690b9d91ac1315566ba299916140f4cbef3cf8b0db480527b1c9a15139ea80d15a8a53eba9bc56>, pool_contract_puzzle_hash=None, plot_public_key=, file_size=108835106222, time_modified=1624814581.1686323)
2021-10-02T02:53:05.396 harvester chia.harvester.harvester: ERROR Error using prover object badbit or failbit after reading size 2 at position 108654967038
2021-10-02T02:53:05.397 harvester chia.harvester.harvester: ERROR File: P:\Plot 8 8tb SOLO\plot-k32-2021-06-20-11-28-456af1e7775d306107305d4f2f6d08bccb2d77cbb7f61b36f71513eff7366400.plot Plot ID: 456af1e7775d306107305d4f2f6d08bccb2d77cbb7f61b36f71513eff7366400, challenge: dc13691a0643b98acc8bc5e96139a9257d265ea7dfca3c6dbe1fd2c92b053268, plot_info: PlotInfo(prover=<chiapos.DiskProver object at 0x0000022326CD20B0>, pool_public_key=<G1Element 896acfdab07f4394cc690b9d91ac1315566ba299916140f4cbef3cf8b0db480527b1c9a15139ea80d15a8a53eba9bc56>, pool_contract_puzzle_hash=None, plot_public_key=<G1Element 8cbc4fe07500e4972f265b5a906f1a9253959730162d560e817f1cdffaafcdbbac02847c4ff880ea17743cdc808ec43e>, file_size=108835786038, time_modified=1624186857.5380187)

Manually check the plots are the right size, and not part files that copied across and couldn’t finish.

It can be a corrupt file, bad drive or I/0 error from my exp.

It’s strange that it will be perfectly fine for hours, then it suddenly starts and all over the place, no real pattern.

I have checked plots, changed usb ports, installed drivers. It’s just so random, it doesn’t drop the drives so I can still access them. I’m at a loss

Don’t suppose you are using external USB docks?

I am for some of them

I am thinking it’s the forks I am farming as well maybe clogging up the bandwidth?

OK, well badbit / failbit were my first errors I saw.
But then I got long times for looking up qualities.

1 week later its still not fixed…
Check your event viewer for error 153, I believe this is the cause.

My long thread… where I’m still trying to fix it.

FYI, I no longer get badbit failbit after after deleting the shown plots.
I also removed a drive that was showing critical with crystal disk.

There’s in win 10, more than one place you need to stop things sleeping.
All in my thread.

Good luck

I farm no forks, so prob rule that out.

Just been through your post, I’m having that exact issue. Been through most of the suggestions. And power settings definitely isn’t the issue.

Keep me updated. If I solve it I shall let you know.

And I’m no wizz, but should know enough to be able to fix this :roll_eyes:

1 Like

I’ve been reading on online.
I’ve just updated 7 usb drivers, if that doesn’t help I’ve a few other drivers to try.

I’ll def let you know if I get it fixed, real pita.

I have this on all of my portable devices, try to update driver but it tells me its the latest one.

Remove the config file and restart your pc and then add all the plot folder again

1 Like

I think this may actually solve this issue. Last night I did exactly this by accident and it’s been running for the last 14 hours problem free.
If this is the case then my hunch of a chia software issue is correct.

When I originally installed the external hard drives they were given a drive Letter and I also mounted them as a folder. When they were full of plots I would delete the drive Letter and point chia towards the folder I had mounted the drive in.

Recently I’ve given half of my drives letters so that I could convert them to NFT plots. So these letters will almost certainly be different from the original letter assigned to it the first time it was plugged in. Last night I deleted all of the drive letters and just left the folder address. Then re added the folder location back into the gui/config yamyl.

At every stage I am careful to make sure the plot directory is up to date in the chia gui/config yamyl.

Either way deleting the config yamyl, and re adding the plot folder seems to have solved the issue.

I’m not saying 100% yet as it’s only been 14 hours, but that’s the longest it’s gone without issue for weeks and weeks.

1 Like

Has anyone else managed to fix this?

Yes, I fixed mine.
Some were part files that didn’t fully copy to hdd, so the last file added wouldn’t quite fit, I deleted those, my others were from a dying drive, so I removed that.

I now get no badbit / failbit issues.