Error using prover object Src size is incorrect

OK so I am seeing this in the debug logs:

Error using prover object Src size is incorrect

2021-04-23T22:06:06.938 harvester chia.harvester.harvester: ERROR
File: \\\public\chia-plots-1\plot-k32-2021-03-29-17-30-1da935c2c29fb8c2c723896f53f9a23e420d49f03f287d7760d516fa0b7e1c89.plot, 
Plot ID: b'\x1d\xa95\xc2\xc2\x9f\xb8\xc2\xc7#\x89oS\xf9\xa2>B\rI\xf0?(}w`\xd5\x16\xfa\x0b~\x1c\x89',
challenge: bcfb7bed2c7eab41a61d908ae667d7982733a69b29398507ee67d822557bc012,
plot_info: PlotInfo(prover=<chiapos.DiskProver object at 0x00000158DCD191F0>,
pool_public_key=<G1Element b59e5c3f507029ac4bbff11e00aac05588effc49d210273080ee17f0fcbdf09c70501ce9aa2686411d00ed3bc8d77814>,
plot_public_key=<G1Element 85e50d8a4194fea7ff2bd7f18101dbf0a63d610a6b4a1569835e2043b58b96dcec398a5d11edbe2415bd87bb605cbc81>,

Someone on Reddit said that does indicate I may have a bad plot!

so I ran the check like so

.\chia plots check -n 30 -g plot-k32-2021-03-29-14-48-cc85c222721bef984ca7db765790df34690406701900a0c55c5ff26d6cddade1.plot

And sure enough, it says the plot is bad!

Starting to test each plot with 30 challenges each

Testing plot \\\public\chia-plots-1\plot-k32-2021-03-29-14-48-cc85c222721bef984ca7db765790df34690406701900a0c55c5ff26d6cddade1.plot k=32
Pool public key: b59e5c3f507029ac4bbff11e00aac05588effc49d210273080ee17f0fcbdf09c70501ce9aa2686411d00ed3bc8d77814
Farmer public key: 8d577c6df158f02314668bdb591de52a0ddc1b04c45f99d81ffaba5ccb0b27dc4fd5918725d9df94cef414971a753db5
ERROR    <class 'RuntimeError'>: Src size is incorrect error in getting challenge qualities for plot \\\public\chia-plots-1\plot-k32-2021-03-29-14-48-cc85c222721bef984ca7db765790df34690406701900a0c55c5ff26d6cddade1.plot
ERROR       Proofs 0 / 30, 0.0
Found 0 valid plots, total size 0.00000 TiB
WARNING  1 invalid plots found:
WARNING  \\\public\chia-plots-1\plot-k32-2021-03-29-14-48-cc85c222721bef984ca7db765790df34690406701900a0c55c5ff26d6cddade1.plot

Dang, I didn’t realize plots could come out bad… I guess I’ll be checking the debug log more closely and deleting these plots??

I’m also scared because all my plots are checking out bad? I picked a random one and it also produces this error? :scream:


Uh oh. Let us know what your plot checking returns!

Actually I just checked another one and it passed so phew not all of them. But quite a few seem to be bad! WTF?

Testing plot \\\chia-final-y\plot-k32-2021-04-20-04-34-938dc97711b9f71981d50983dffc6c00d13e6d801c0c1fe7cbfdc121f14b3b64.plot k=32
Pool public key: b59e5c3f507029ac4bbff11e00aac05588effc49d210273080ee17f0fcbdf09c70501ce9aa2686411d00ed3bc8d77814
Farmer public key: 8d577c6df158f02314668bdb591de52a0ddc1b04c45f99d81ffaba5ccb0b27dc4fd5918725d9df94cef414971a753db5
Proofs 13 / 10, 1.3

Found 1 valid plots, total size 0.09895 TiB
1 plots of size 32

Well damn. I can go to bed at least, I was worried all my plots were bad :scream:

Looks like the ones in the debug log are indeed bad plots though, all the ones I check turn out to be bad, so I should auto-delete those… sheesh… what’s up with these bad plots, where are they coming from?!

I’d move one that says it’s bad to a local disk and check it again just to take all of the networking and the second machine / NAS out of the loop.

I’ve seen this happen when the plow machine’s processor is manually overclocked because it messes with the PCIE bus speed.

1 Like

Hmm yeah none of my plotters are overclocked to my knowledge, but that would make sense. I’ll keep an eye on any patterns that emerge…

Here’s a regex that matches the correct lines in the C:\Users\user\.chia\mainnet\log\debug.log


And the command you use to test is

.\chia plots check -n 5 -g {filename}

Overnight 3 files emerged as bad from my debug.log and I checked them all, they are confirmed bad via the above command, and I deleted them. It looks like you can use a wide variety of forms for {filename} including:

  • the full path to the file

  • just the filename

  • just the guid (the end plus .plot)


I think -g doesn’t have to be the filename. According to CLI reference it’s just a substring:

Command: chia plots check -n [num checks] -l -g [substring]

From: CLI Commands Reference · Chia-Network/chia-blockchain Wiki · GitHub


Yeah, I agree, it seems to match any unique part of the string, so you can also use it for dates, like “test all plots created on this day”


or “test all plots created on this day and hour”


or even “test all k32s”


1 Like

Checked my logs and found a bad plot… killed it. Doing some chia checks now on various dates. (while this is running, a few seconds are added to my farm response times.)

1 Like

Yeah the logs will WARN or ERROR if they find bad plots, so it’s a good idea to grep your logs for that periodically… as I covered in Protip: check your debug.log regularly

1 Like

I found this error in my logs, anyone have any insight if this is something of concern, or just potentially a bad plot?

2021-04-27T11:04:56.999 harvester chia.harvester.harvester: ERROR    Error using prover object Src size is incorrect
2021-04-27T11:04:57.014 harvester chia.harvester.harvester: ERROR    File: /run/user/1000/gvfs/sftp:host= Plot ID: b'\xc1\x14\xc8\xb0~\xa0\xfa\xb1\x97m\xec\xf5\x98u\xd0\x18\xc6\xa4`R_\x889\x13\xb4S=W#\x07q"', challenge: ff6f1853858d7ff7106d560a518a97b3a8ec6d8f7a5db5b450ac480b8a2e35a1, plot_info: PlotInfo(prover=<chiapos.DiskProver object at 0x7f31d803a030>, pool_public_key=<G1Element ...>, pool_contract_puzzle_hash=None, plot_public_key=<G1Element ...>, file_size=108838629376, time_modified=1619076348.0)
1 Like

Yeah it’s a bad plot. You can use chia plots check to confirm it… I’ve found & deleted 2 of mine for this.


I had a spate of bad plots lately, I think the way I was copying them off the NAS was corrupting them :disappointed: … but this command is absolute gold for finding bad plots. You don’t need to set the iterations very high to find them, either.

In addition to the previous sequences, I like doing it per-drive, per date, like so:

.\chia plots check -n 5 -g K:\plot-k32-2021-04-02

This’ll quickly check all plots on that drive (K) created on 04-02-2021 which is handy. (Five is the minimum number of checks, but it suffices for my purposes.)

1 Like

@codinghorror I have one server which creates plots with <class 'RuntimeError'>: Src size is incorrect error in getting challenge qualities for plot error 100% of the time so I’m trying to determine what exactly on this server is causing this behavior. Note that plots check with -n 5 passes for me on all these plots, but as soon as I do -n 10 all of them fail. Good thing that I checked these plots when dropping them in to my harvester as harvester log did not show any issues with these plots during farming.

1 Like

This server passes memtest and prime95/mprime overnight?

I know what caused my bad plots in this case, I copied them in a weird way… that’s on me.

The built in pre-boot men test passes and Prime95 does not report any errors/warning although I could not run it overnight. I think something may be causing this at the RAID used for tmp location or possibly ReFS used on the tmp as well. I’ll try creating a plot on an external drive to test.

1 Like

You gotta run the full memtest, the pre-boot test is not nearly enough.

Does not look like it is CPU or RAM related as I tested plot creation agains an external HDD via USB3 and resulting file checks out fine. It is either something with ReFS file system that is on the tmp drive or the RAID controller for tmp drive. I will try to do some testing on ReFS with an external or iSCSI drive to confirm if it is that as I would be really surprised if it was this ent. grade RAID card.

1 Like

I am seeing a few of these errors “Error using prover object Src size is incorrect” or “Error using prover object Error (generic)” or “Error using prover object Invalid size for deltas” but every time I run it against plots check with n = 30 or even 100 against the specific plot it passes so I am not sure what these errors mean?