Failed to fetch block from none?

Hello guys,

Do you know where is the problem with my solo farming? The lines below are in my debug.txt file:

2021-05-30T15:46:30.193 full_node full_node_server        : ERROR    Exception: Failed to fetch block 358751 from None, timed out <class 'ValueError'>, closing connection None. Traceback (most recent call last):
  File "chia\server\server.py", line 536, in api_call
  File "asyncio\tasks.py", line 414, in wait_for
  File "chia\server\server.py", line 533, in wrapped_coroutine
  File "chia\server\server.py", line 526, in wrapped_coroutine
  File "chia\full_node\full_node_api.py", line 104, in new_peak
  File "chia\full_node\full_node.py", line 373, in new_peak
  File "chia\full_node\full_node.py", line 322, in short_sync_backtrack
  File "chia\full_node\full_node.py", line 307, in short_sync_backtrack
ValueError: Failed to fetch block 358751 from None, timed out

2021-05-30T18:43:00.924 full_node chia.full_node.full_node: ERROR    Exception in create outbound connections: 
2021-05-30T18:43:00.925 full_node chia.full_node.full_node: ERROR    Traceback: Traceback (most recent call last):
  File "chia\server\node_discovery.py", line 378, in _connect_to_peers
  File "asyncio\tasks.py", line 595, in sleep
concurrent.futures._base.CancelledError

Thanks.

Do you have a lot of these lines or just a few? Is your node synced with the network?

Node is synced, everything looks fine and farming with 128 plots but I´m not sure if correctly…
Is there any 3-rd party tool to optimize the farming process?

Hi! Do You solved this issues? I have the same and don`t know what to do.

Not yet, but for now, I decided to try the HPOOL with my 14 TB drive plots. I will continue plotting once the official pool is ready.