Failed to open (invalid plots)

Hello, I have about 4,6 TiB in plots (46 k-32 plots). I plot on different machine, put my plots on my cloud.
Everything was working fine until 2 days ago, when I added 20 more finalized plots to the directory. I refreshed the plot list in Chia Blockchain app, but I only saw 26 plots farming. After a while there was a Failed to open (invalid plots) section with all the new plots on the list.
So I removed the whole dir from the Chia app and added again and now all the plots were shown as invalid. I tried restarting the GUI, restarting my PC, re-adding the wallet, updating to 1.1.6, removing the plots to another directory. Nothing helped. After some time of running, some plots were shown as farming again, but not all of them. Now nothing helps, wallet synced, full node synced. I get the same message everytime :frowning:

I have a regular laptop where everything was running fine, it’s used only for farming - i7, 4 threads, 8 GB RAM. Now I am just not able to farm my plots, but I am sure they are not damaged.

I get this message from chia check for each of my plots:
2021-05-24T11:45:22.278 chia.plotting.plot_tools : ERROR Failed to open file G:\Můj disk\46plotov\plot-k32-2021-05-22-08-30-1a037e0fb83b9385dc038c5bb3789213737698010c0d6db085c843482542e3f4.plot. Invalid file G:\Můj disk\46plotov\plot-k32-2021-05-22-08-30-1a037e0fb83b9385dc038c5bb3789213737698010c0d6db085c843482542e3f4.plot Traceback (most recent call last): File "chia\plotting\", line 189, in process_file ValueError: Invalid file G:\Můj disk\46plotov\plot-k32-2021-05-22-08-30-1a037e0fb83b9385dc038c5bb3789213737698010c0d6db085c843482542e3f4.plot

Any help please?

When I transfer my plots using a drive to my farmer, sometimes I face the same issue - I read somewhere in Chiaforum that you rename.plot extension to.temp…transfer the file and rename the extension to.temp again - I would do one use a copy of the file so you have an original in backup, transfer it to test if it works (copy files rename with (1) you will want to remove that as well). Then do in chunks of 3 to ensure all files transfer safely…although to cloud backup could be an entirely different case…

1 Like

I tried that also - I transfered some of the plots by renaming to .tmp to another directory, then renamed back - this did not help too. I would understand, that some plots could be damaged by uploading to cloud, but not all of them including the previous half which had worked correctly.

I think clouds have various compression mechanisms that would render plot files unreadable by the software, perhaps?

as I said, it was working fine for few days, so the cloud is not a problem. I have cloud mounted as a drive.

Speak with cloud support?

that will not help. same happens when log in to another PC which has plot files on HDD

From the command prompt (or terminal, as the case may be) run:

chia plots check -g filename_of_plot

If the “chia” executable is not in your $PATH, then you will either have to add its directory to your PATH variable, or cd to the directory in which it exists (will work in Windows), or spell out the full path from the root to the executable.

If the plots do not pass the checking criteria, then there is something wrong with them.
If the plots do pass the the checking criteria, then I cannot help you, as it would be odd for the check to deem the plots to be valid while the GUI claims otherwise.

1 Like