FARM ON 2 PC (Ubuntu)

Hi guys, so I’m using Ubuntu and im using 2 Pc’s. One of the pc work like a farmer/harvester…… and I want to use the other one “only” as a harvester with the same wallet etc.

But the question is now, how do I do it on Ubuntu? :face_with_monocle:

If you mean you have two systems with harddisk connected holding plots, it is better to run one as a full-node (farmer/harvester/wallet) and the other as just a harvester.

If other reasons to ‘farm’ on 2 PC’s, please explain so others can think with you for a solution.

1 Like

That’s you are right…. I hope it gives more sense now :sweat_smile: I have just edited my question :+1:t2:

But is that for Ubuntu? :face_with_monocle:

The github wiki is more of a generic explaination, so also valid for Ubuntu but not specifically.
It took me some headache to realize that something that reads as pretty complicated in practice is quit doable with three steps only on the harvester-to-be machine.

  1. make a temporary copy of the ssl keys of the farmer and create derived keys in chia for the harvester
    (step 1 equals 3 cli commands in ubuntu)
  2. adjust the [harvester] section of chia’s config.yaml file to point the harvester to the farmer
    (two or three lines to be added)
  3. start chia as harvester-only instead of full-node
    (chia start harvester -r in cli)

If you want more detailed help i need to know:
are you currently running chia full-nodes on both machines? what versions have been installed on both machines? are you using the gui or just cli commands?
did you install by means of the one-step installer download from or the ubuntu instructions on github? (those install binaries into different directories …)
do you have experience in cli or rather how detailed i have to be;-)

1 Like

Hi, I have downloaded the Chia blockchain .deb file and installed it on both PCs. And I have used the 24 key words to make the same wallet on both PCs.

And regarding the plots…… I have just added the plots dictionary in both chia GUI …. That’s it.

Can you please share the Ubuntu command for the 3 for the cli.

I have not used cli before :sweat_smile:

Ok, first can you provide some details about the pc’s?
CPU, RAM, OS drive (HDD,SSD,NVME) and number of disks/plots you want to configure on each?
This to choose which one will be full node and which will be harvester?
And Chia versions installed?
I’ll start working it out for you in the meantime.

On second thought, to save you -and myself- some possibly unnecessary work, why 2 pc’s? Farming chia is a long term project anyhow and (power)efficiency can well be the difference between profit and loss…

1 Like

Yes is see but I’m thinking long term and would like to invest in Chia… I have 1 pc that I use for plotting and harvester and I need to add one more pc as “Only” harvester.

Hope this is helpful…… I just uploaded a picture of the chia GUI

Ok, thanks.
Hope this is not a recent picture… if it is you are a few versions behind but stranger is the 963,785 at the bottom. We’re currently at Height 1.185.391 so you’re not properly synced on the blockchain…
Both are separate issues, I’ll provide some instructions to set up on of the machines as harvester only but check out the issues mentioned please.

1 Like

Hi yes I have not updated the GUI in some while and I’m currently sync. With the blockchain :+1:t2:

But I will update the chia GUI when the sync. Is done :white_check_mark:

Ubuntu cli setup below. Don’t forget the line to backup the config.yaml file. No guarantees of course, don’t know of any issues your specific machines may give but i think this should work. In case of major problems only thing really changed is the config.yaml file so with the backup you can always revert to the full node situation and run full node again (don’t run GUI in harvester-only mode…)

On harvester machine exit Chia and reboot ubuntu to stop all processes.
After reboot click Activities (top left) and type ‘terminal’ in the search box and click Terminal icon.

(We’ll use sudo command to be temporary superuser and prevent permission issues, the # are comments no need to type those;-) You’ll have to provide your password when using sudo!

#STEP 1:
sudo mkdir /ca_temp_dir			# make directory for temporary storage farmers ssl certs

sudo scp <user>@<farmer-ip-address>:~/.chia/mainnet/config/ssl/ca/*  /ca_temp_dir	#copy farmer certificates to temp directory

sudo chmod 777 -R /ca_temp_dir		# set permissions temp folder

cd /usr/lib/chia-blockchain/resources/app.asar.unpacked/daemon	#  go to chia binaries folder

./chia version							# check chia version, just testing

./chia init -c /ca_temp_dir		#create certificates to enable secure communication with farmer; this command will give a warning about to too open permissions and offers a fix, you can do so, but the certificates are created anyhow. 

#STEP 2: 
sudo cp ~/.chia/mainnet/config/config.yaml  ~/.chia/mainnet/config/config.old	# backup just in case

sudo nano ~/.chia/mainnet/config/config.yaml		# start nano editor on config.yaml, use cursor keys to navigate!

#In config.yaml find the lines  under [harvester:] section		 -  they look something like

*  chia_ssl_ca:*
*    crt: config/ssl/ca/chia_ca.crt*
*    key: config/ssl/ca/chia_ca.key*
*  farmer_peer:*
*    host: localhost		#here change ‘localhost’ to the ip address of your farmer!*
*    port: 8447*
*  logging: *id001*
*  network_overrides: *id002*
*  num_threads: 30*
*  plot_directories:*
*  - /mnt/chia/plots1	#here use your own paths to plot directories, probably already there*
*  - /mnt/chia/plots2*
*  - /mnt/chia/plots3*

#Press Control-O and Enter to write the new config.yaml
#Press Control-X to exit nano

#STEP 3: 
#still in path /usr/lib/chia-blockchain/resources/app.asar.unpacked/daemon…

./chia harvester start -r			#(re)start harvester

#on your farmer machine, while running chia full node GUI, start Terminal and

cd /usr/lib/chia-blockchain/resources/app.asar.unpacked/daemon	#  go to chia binaries folder

./chia farm summary

#This should show your local (on farmer machine) harvester, as well as the remote harvester with its ip-address and nr. of plots

#If all is well, remove farmer certificates from the harvester machine, no need to have them there

sudo rm /ca_temp_dir/*
1 Like

Omg that looks a bit hard :sweat_smile: I will try it soon, may luck be with us…….

Thanks :blush: :rose:

Regarding the local host on my main computer…… should I just use my ip from the website : whatsmyip ??? :face_with_raised_eyebrow:

No No, see link below, look for part that says Checking IP address in Ubuntu [GUI Method]

I assume you have internet from some provider with a router (wired, wireless) to connect you devices on. It’s about the local ip addresses, not you public IP that will show.

Also important is to have the ip address of the farmer machine fixed, a reboot might otherwise lead to another ip-address that your harvester can’t find anymore. Also your port forwarding to the full node machine may go into the blue then.

I’m getting the idea this may not be a good idea for a first timer on linux… Can’t you stick to just one machine for the time being and learn some basics first… no offence of course;-)

1 Like

so i have tried 2 times… i get this error…

First error my fault, it seems a file ca-temp already exists so can’t create a directory with the same name.
Please replace ca-temp with ca_temp_dir everywhere used, that should work.
Second error also my fault i guess, but Ubuntu desktop standard has SSH access disabled so you cant connect.
To fix, a few more commands, see
Do this on the farmer machine, don’t think its needed on the harvester unless you want to run that machine headless (no screen,keyboard,mouse attached) later on and want to connect from your laptop for instance.

On first connection from the harvester to the farmer (the scp command), it will say something like
The authenticity of host ‘ (’ can’t be established.
ECDSA key fingerprint is SHA256:UKsvqmQuHHYvVPXQEp7rSgxNNYpsKzuiqyGLSUlfhwM.
Are you sure you want to continue connecting (yes/no/[fingerprint])?
Type yes and continue…

I updated the steps in my post above. Also the scp command should be:

sudo scp user@farmer-ip-address:~/.chia/mainnet/config/ssl/ca/* /ca_temp_dir

user is the user at the farmer machine, also chia i suspect?!?

Must have done all this myself some time ago, just forgot about it…sorry

1 Like

thansk for your time, but i still get an error at the shh command. Please see below


as you can see the ssh looks correct… but still no connection