Farmer suddenly shows "Have multiple copies of the plot..." on Chia V1.2.6 and 1.2.7

Hey there,

strange things started happening after installing V1.2.6:

“Have multiple copies of the plot …”

which is a total b/s since there are zero duplicates of my blocks. My farmer never had this behavior before, so did anyone notice this too?

And no, its not just the GUI, its in the logs too.

Its quite annoying since the plots “degrade” to 50% over 24h, so I have to restart chia at least every 4 hours to have all my 2800 plots eligible for farming.


UPDATE: Deleting all plot directories and adding them does not solve the problem.

did you run the chia plots check before on since?

chia plots check -n 1 -l

will list all duplicates, if that shows the same than you actually have duplicates, if not then something is wrong with the gui

Thanks for getting back. I tried chia plots check -n 1 -l - nothing comes up.

Weird thing is, that also the logs show those duplicate errors, so unfortunately its not only the GUI :frowning:

I have seen this error where a USB drive loses contact and re-attaches automatically. I don’t know if you are using many drives but 280TB sounds like it. Try stopping the chia processes and checking all the drives are mounted in the places you think they are.

I am having the same issue, resulting in losing over 1,000 plots from being farmed.

The problem hit me with version 1.2.5
(I jumped from 1.1.7 to 1.2.5).

I just installed 1.2.7, and the problem persists.

However, if I set-up config.yaml to farm only 1 of the drives that it believes has multiple copies of the plot, then all of that drive’s plots are validated / recognized. But when combined with all of my drives, the harvester falsely tags them as duplicates – and I am 100% positive I have no duplicates.

Have you resolved the issue?
If yes, please let me know what you did.

Thank you.

Hey Seymour,

I almost gave up hope that somebody else got the same issue - until your post :slight_smile:

I am losing up to 1700 plots over 48 hours with the duplicate message. I am also 100% sure there is no duplicate at all.

Since now the issue is unsolved; I’ve tried deleting all the plot drives within Chia and set them up again. That did not help.

At the moment I keep an eye on the logs and whenever a duplicate found on drive XYZ comes up, I delete the drive within Chia and reconnect it. All plots are recognized again until, a few hours later, this process starts again…

This is very frustrating since I believe it is just a Software bug :frowning:

I suspect that others have the problem, but are not aware of it.

You would think that they would notice a dip in their plot count. But some folks are not observant.
And fewer, still, know about the debug.log, its location, and are brave enough to examine its contents.

Since no one in this forum is able to help us…
Do you know of any other forums that have talented people subscribed that can help, or do you know how to open a bug report with the Chia developers?

Perhaps this was reported to the developers. But I do not know how to check on that.

Very good question, indeed!

I was going to open a discussion on reddit/chia too, but lets see if more people join this thread first. Since we share the same pain just our of curiosity: I run Windows Server 2019 and all plots are 10g network attached to Synology non-raid nas drives. Never had a problem since April until V1.2.6

What is your environment? chia bug report

1 Like

I am running Windows 10 Home, on two computers. Both are doing plotting. Both have many USB drives connected.

The drives that have the supposedly duplicate files are all on the networked computer.

I have all of my USB drives connected via an NTFS mount (not the traditional drive letters, which would be unwieldy for numerous drives). The drives are mounted similarly to how Linux mounts drives, via the directory of your choice.

And for my main computer (not sure what that is called in Chia lingo), I am able to access all of my remote drives, by way of a single drive letter. This is because the remote machine is connected via “map network drive”, and once connected to that network drive, all USB drives are mount points on that file system.

This makes for very easy searching and management, as all drives on each computer are mount points from a single directory.

I have only two computers. So I have them networked via a Cat 7 cable (no switch needed). The motherboard’s built-in NIC runs at 2.5 G-bit on both computers.

I feel confident that this is a Chia bug.

I opened a BUG report on Github - thanks @dreamboatcap for the link!

I’ve come across that since .15 or .16 iirc.
Be nice if it gets fixed but don’t hold ya breath.

Have you checked to ensure that your USB and your HDDs are set to never sleep and/or high performance mode in the OS and BIOS?

I can’t say it was literally the ssd, as I also moved all disks to my much faster plotter, but, some warnings, iirc spendbundle or ??? ( to do with adding transactions) warning literally said to move chia to a faster drive.

Being as u was on ss, and am now on 3.2 type a ( same speed 5gb) I’m assuming it was just the ssd.

My longest time for last week is 2s, vs 30s or 50s before moving drives.

Assuming you were talking to me… maybe not, if not ignore my drunken rambling

Hey Bones. I am familiar with your struggle. Glad to hear you are down to a 2 second longest response time. Sounds like you have succeeded in catching your bug.

I was more talking to some of the others who seemed to have the problem of plots disappearing or seemingly duplicating on a semi random basis.


I still have over 800 plots that Chia deems to be duplicates, and, therefore, under-reports my plot count.

I have checked several of the plot names that are supposedly duplicates. None are.
I run NirSoft’s “SearchMyFiles.exe”, and choose the option to report duplicate file names, based on the locations you tell it to search.

All of my plots are located under one directory, as NTFS mount points, on each of my two Chia computers. So I have only two directories (one on each computer and their numerous sub-directories) to search. I give NirSoft’s tool the two top-level directories, and it searches everything there and in all sub-directories.

NirSoft’s SearchMyFiles.exe reports zero duplicates.
I also test the searching tool by creating duplicate file names of plots. The tool catches the duplicate names every time, even when I put the duplicate name on the other of my two computers.

I am 100% certain that I have zero duplicate plots. Yet Chia’s logs claim otherwise, resulting in me not being credited for over 800 plots.

If I knew that it was safe to re-install an older version of Chia, I would, because I am confident that that would fix my problem.

But I would rather be safe, with 800 missing plots, than risk performing a version rollback that would make my set-up unstable or corrupted and unusable.

I found a new Chia site looking for an answer.

This issue has been reported and escalated at:

There is a download/possible fix on this page but I don’t think they really have the bug stomped yet.

I suggest trying the download, and please report whether this fixes your problem here, but more importantly, on the page I linked.

This bug usually appears on systems using NAS, slow USB, and/or non standard file systems.

Some machines having this problem also drop sync regularly. I am not sure if dropping sync is part of the problem or caused by it.

Do you have any Double Spend errors?

1 Like

I saw that you opened a bug report:

and that on 09/27/2021, " loppefaaret" wrote:
“yes, that should hopefully fix the issue, if you dont mind running it”

I tried to follow the conversation, but it was a bit too technical for me.

Were you able to resolve your false duplicate, plot under-reporting issue?
If yes, can you walk me through what you did to resolve the issue?

Was it fixed in a newer Chia version? Or did you modify an entry in a config file?

Please advise.

Thank you.