Final stretch with fixing remote harvester issue. Plots not reporting, plotnft empty

I’ve put everything through the ringer to get here and the last issue is my remote harvester isn’t reporting plots to the full node. The plotnft that these plots are associated with also comes up blank. I did a lot of deleting, reinstalling, config editing to recover from the weird failure that caused this last week and now I’m stumped. Last weekend, at some point, I lost power while away and on return the full node needed to be recovered. Upon getting back into my wallet/node I noticed the harvester was no longer showing plots and after following a rabbits hole worth of year old guides, I’m finally back to that original issue. Idk what else to do at this point. Something tells me it’s a plotnft/key/plot mismatch, but I honestly don’t care at this point. it worked, it stopped working, and its still not working a week of fixes later.

*I’d updated in the middle of all these changes too, so there was the added issue of needing to recertify the harvester on top of everything else.

Which chia version are you running? What OS?

Maybe you can start with:

  1. stop your harvester
  2. comment all folders but one (to simplify logs)
  3. delete your debug.log
  4. start harvester
  5. wait one / two minutes, and post your debug.log here, as we would like to see:
    5.1. does it see that one folder and plots there
    5.2. does it try to connect to the node, and eventually what error is there
    5.2.1. not reachable IP / port (can you ping that IP?)
    5.2.2. blocked port (can you telnet to that IP / port)
    5.2.3. wrong SSL certs (logs will have SSL error; node should also show that it refused that connection)

1.3.5 on both machines. Node is Win10, Harvester is a proxmox ubuntu vm.

The harvester is actually being challenged, I know that much from previous logs. Ping goes both ways.
Waiting on the log to populate now.

I’ve just been a little braindead this week. This happened a while back and I resolved it within a few hours, but adding all the extra steps and keys issues on top hasn’t helped.

From your Ubuntu, run telnet IP 8447 as that will show whether the port is not blocked by the Win firewall.

You can also try “openssl s_client -connect IP:8447” and check what SSL cert will be reported.

You don’t need to wait too much for those logs to be produced, as virtually everything will be there in the initial lines (just strip redundant plots).

The harvester log is just showing “# plots were eligible for farming” and nothing else.

Telnet worked fine

Wasn’t 100% on what I was looking at with openssl, but Chia Organic Farming Division is mentioned. It does say “No client certificate CA names sent” towards the bottom, if that matters.

Yeah, all that is good. The point with s_client was to check whether SSL handshake can be started, and returned cert is from Chia. Although, it doesn’t say whether proper certs are on both sides (i.e., whether chia init -c is potentially missing - the log will have SSL error).

Do you have those lines in your debug.log (at the very beginning)?

2022-05-22T00:01:44.868 daemon chia.daemon.server         : INFO     Starting Daemon Server
2022-05-22T00:01:44.868 daemon chia.daemon.server         : INFO     Not implemented
2022-05-22T00:01:46.931 daemon chia.daemon.server         : INFO     ConnectionClosed. Closing websocket with Unknown
2022-05-22T00:01:48.602 harvester harvester               : INFO     Started harvester service on network_id: mainnet
2022-05-22T00:01:48.602 harvester harvester               : INFO     Reconnecting to peer {'host': '192.168.200.145', 'port': 8447}
2022-05-22T00:01:48.634 daemon chia.daemon.server         : INFO     Register service {'service': 'chia_harvester'}
2022-05-22T00:01:48.634 daemon chia.daemon.server         : INFO     registered for service chia_harvester
2022-05-22T00:01:48.634 daemon chia.daemon.server         : INFO     {'success': True}
2022-05-22T00:01:48.634 harvester harvester_server        : INFO     Connected with farmer {'host': '192.168.200.145', 'port': 8447}

I mean, the last two show whether your harvester can connect to your node (SSL certs are correct).

Yup, everything’s there.

So, if your harvester is happy, your node should also be. Do, you still see problems on your node?

buggered that edit up

Is that in your harvester’s debug.log? How many plots are on your harvester?

This is rather a normal log entry, if the number of logs is low (say less than 500 or so). It just means that a new challenge was given to the harvester, and it didn’t find any plots that are close to that particular challenge.

This is from my node. i’ve got 839 on the harvester

Node doesn’t report that with respect to your remote harvester, only with respect to the local harvester. So, the same question stand, how many plots you have on your node.

Both harvesters act in the same way, where one connects via a specific IP, the other via 127.0.0.1, but operation is identical on both.

When you go to your Farming tab, in the Last Attempted Proof you should see in the second column something like 1/1000, where the first number means how many proofs were found, and the second how many plots a given harvester has (whether local or remote). Also, at the bottom of that page. It should change every 10 seconds. If you expand the Advanced Options section, you should see all your harvesters there. Lastly, when you go to your Plots tab, you should see the list of your connected harvesters and the number of plots on each.

The harvester’s there right below local, with no reported plots. I should of mentioned at earlier in the week the gui/cli would stall of the harvester step. I downloaded the updated config file and carried as much of as I knew to. When I throw the old config in there I can see the plots via cli, but can’t access the gui as it stalls on the harvester step. That was the genesis of this particular problem.

The farming tab reports on plots even with the harvester appearing in advanced.

I’m just gonna keep tweaking until I get it back to a pre-this mess state.

Cheers for you patience

From what you just have described, you have messed up your config.yaml on your node. I would start over with your old config, and just bring new lines that make sense to you. Your old config should be sufficient, so you don’t need to feel any pressure to get it quickly updated with the new stuff (I run on the old config, and all is fine - from v1.2.11 or older).