Guide me to get most of my 3990x rig

Hi guys,

Here is my specs:

AMD Ryzen Threadripper 3990X 2.9GHz 288MB 64 core 128 thread
Gigabyte TRX40 AORUS PRO WIFI
7x PNY XLR8 CS3030 M.2 NVMe 2TB (RAID0 already tried without RAID) 3 on MB M.2 slots and 4 in Gigabyte AORUS Gen4 AIC Adapter. PCIE is set to 4x4x4x4x
7x Seagate 16TB ext4
Corsair 128GB (4x32GB) DDR4 3200MHz CL16 Vengeance
Power: Corsair RM1000x 1000W

7 Jobs and We tried both 4 and 2 threads. It is pretty fast till first 14 plots but after that It goes damn slow. We monitored the system and see no pressure at all for any component. seems like with more parallels jobs the CPU usage doesn’t go higher and every job just gets slower. can’t figure out my bottleneck.
there was 1 job per NVME and each job will write to it’s own separate HDD with 30 mins of staggering, make sense, doesn’t?
now all 7x NVME are in RAID0 and it’s almost the same situation.
I am using Swar plot manager and here is an example of my jobs

JOB1 to 7

size: 32

bitfield: true

threads: 4 or 2

buckets: 128

memory_buffer: 3400 or 3389

max_concurrent: 7

max_concurrent_with_start_early: 1

stagger_minutes: 30

max_for_phase_1: 6

concurrency_start_early_phase: 1

concurrency_start_early_phase_delay: 0

temporary2_destination_sync: false

Please any suggestion!

Some good info for all these question are linked right from this category’s description you know… :wink:

We recommend reading it, trying it, and then asking additional questions you might have!

2 Likes

Check out this video, should help with your Swar setup:

1 Like

have read that few times before posting already, actually have read all the posts in chia farmer and chia decentral already. seems like my nvme s are not up to such a task so switched them with WD black ones, much less TBW but that was my current possible choice, will report back with changes. and yes I am using Swar plot manager for a while

Hey! I was wondering how did you end managing your setup after adding WD Black’s? I am in the similar situation where my plots are bottleneck after few hours. It seems like I’ve tried a lot of things, but nothing really helps. I am currently trying to stagger my plots 3 hours apart and see if that may help.

My current set up is:

7 x 2TB Firecudas TLC NVME

  • 3 are in the MOBO
  • 4 are in the Xpander

7 x Seagate 14TB drives

  • each M.2 writes to it’s own Seagate drive

I have a feeling that the reason it gets bottleneck is because the expander sits on one PCIe slot and it probably can’t deal with all the data that goes in and out through that channel. I’ve checked the temps of the drives, they don’t seem to be throttling or anything like that.

I’m pretty new to this, so I wouldn’t be surprised if I’m missing anything. I will read up on those links Cultiv and SB1 posted, but would like to know how did you manage to get around this? How many plots do you plot per 24hrs and what is your current set up and settings? Would really appreciate your response!

Cheers!