Harvester is not working - no connection to node

Hi there,

hope you can help me, i do not get whats wrong with my setup.
I have a WinServ 2016 running fullnode and a ubuntu for plotting and farming.
FullNode running well, but the harvester.
Harvester can plot, no issue, but with connecting to the full node.

CAs keys were created before.

Running in CLI mode following commands.

chia configure --set-farmer-peer %FULLNODEIP%:8447

sudo lsof -i -P -n | grep chia

chia_daem 41936            chia    8u  IPv4 13987102      0t0  TCP 127.0.0.1:55400 (LISTEN)
chia_daem 41936            chia    9u  IPv4 13986593      0t0  TCP 127.0.0.1:55400->127.0.0.1:54540 (ESTABLISHED)
chia_harv 41940            chia    8u  IPv4 13987128      0t0  TCP 127.0.0.1:8560 (LISTEN)
chia_harv 41940            chia    9u  IPv4 13987129      0t0  TCP 127.0.0.1:54540->127.0.0.1:55400 (ESTABLISHED)

telnet %FULLNODEIP% 8447
Trying %FULLNODEIP%...
Connected to %FULLNODEIP%.

You see above no connection is establised to the full node. Same on fullnode:

.\chia.exe show -c

Connections:
Type      IP                                     Ports       NodeID      Last Connect      MiB Up|Dwn
TIMELORD  127.0.0.1                              50767/8446  71a22af5... Apr 29 16:28:52      6.0|0.0
FARMER    127.0.0.1                              50768/8447  a60afcb0... Apr 29 16:28:54      0.1|0.0
WALLET    127.0.0.1                              50792/8449  36d5e240... Apr 29 18:24:28      1.7|0.0
FULL_NODE 90.254.156.96                           8444/8444  85374979... Apr 29 18:24:56      0.5|2.2
                                                -SB Height:   204934    -Hash: 5ed0b350...
FULL_NODE 136.243.69.235                          8444/8444  4a3e40a4... Apr 29 18:24:57      0.2|2.7
                                                -SB Height:   204934    -Hash: 5ed0b350...
FULL_NODE 84.154.67.123                           8444/8444  7ad1ffd3... Apr 29 18:24:57      2.0|0.4
                                                -SB Height:   204934    -Hash: 5ed0b350...
FULL_NODE 87.79.83.14                             8444/8444  d69484b1... Apr 29 18:24:57      0.3|2.0
                                                -SB Height:   204934    -Hash: 5ed0b350...
FULL_NODE 77.37.144.174                           8444/8444  3d1d04f9... Apr 29 18:24:57      0.3|1.4
                                                -SB Height:   204934    -Hash: 5ed0b350...
FULL_NODE 95.68.83.68                             8444/8444  af75ad62... Apr 29 18:24:27      0.8|0.6
                                                -SB Height:   204934    -Hash: 5ed0b350...
FULL_NODE 173.19.115.55                           8444/8444  81fae4c7... Apr 29 18:24:57      0.2|1.2
                                                -SB Height:   204934    -Hash: 5ed0b350...
FULL_NODE 61.150.12.10                            8444/8444  2752aa07... Apr 29 18:24:55      0.2|0.9
                                                -SB Height:   204934    -Hash: 5ed0b350...
FULL_NODE 95.17.150.139                           8444/8444  4999cebe... Apr 29 18:24:55      0.3|0.2
                                                -SB Height:   204934    -Hash: 5ed0b350...
FULL_NODE 192.99.247.165                          8444/8444  eedeec3f... Apr 29 18:24:57      0.2|0.3
                                                -SB Height:   204934    -Hash: 5ed0b350...

You’ve got a lot of code and terminal results there. If you use markdown to format as code or code blocks it’ll be easier to read: Basic Syntax | Markdown Guide

Individual lines or just commands use a single backtick at the start and end: `

For code blocks start a line with ``` then place the rest of the code underneath and then under the code another 3 backticks

2 Likes

How are you actually running chia?

The following works for me (from memory, but should at least get you on the right track):

  1. Install chia via git, following the instructions up to and including . ./activate.
  2. chia init -c /path/to/ca/dir/from/farmer (see the docs)
  3. Edit config.yaml:
    1. Set harvester:farmer_peer
    2. Set harvester:plot_directories
    3. Set logging.log_level to ‘INFO’
  4. chia start harvester -r to start the harvester

Check logs on harvester and farmer.

1 Like

Check, just, deleted all folder and installed it again.

But after all, it works. Got the connections. Logs looks good, insn’t it?

2021-04-29T20:48:05.022 harvester chia.plotting.plot_tools: INFO Loaded a total of 2 plots of size 0.19802856833757687 TiB, in 0.06859874725341797 seconds

But when i execute chia farm summary, there are errors and Farming Status: not available, is this something i should worry?

Connection error. Check if wallet is running at 9256
Connection error. Check if full node is running at 8555
Connection error. Check if farmer is running at 8559
Farming status: Not available
Total chia farmed: Unknown
User transaction fees: Unknown
Block rewards: Unknown
Last height farmed: Unknown
Plot count: 2
Total size of plots: 202.781 GiB
Estimated network space: Unknown
Expected time to win: Unknown
Note: log into your key using 'chia wallet show' to see rewards for each key

Do you have port 8444 open on your router?

2 Likes

Yep, I do. What’s really unclear to me from the docs is how you take a full node and convert it into a harvester.

I should say the farm summary is from the harvester, not the full node.
On the full node a use the gui, it’s all fine.

I didn’t convert the full node to a harvester. One machine is the node the other is the harvester.

Yes port 8444 is open on my router. And is forwarded to the node.

Did you open port 8447 on your main node? Did you install the certificates on your harvester?

Yes, everything works fine, i think. Just the farm summary of the harvester is a little bit confusing.

chia farm summary
Connection error. Check if wallet is running at 9256
Connection error. Check if full node is running at 8555
Connection error. Check if farmer is running at 8559
Farming status: Not available
Total chia farmed: Unknown
User transaction fees: Unknown
Block rewards: Unknown
Last height farmed: Unknown
Plot count: 2
Total size of plots: 202.781 GiB
Estimated network space: Unknown
Expected time to win: Unknown
Note: log into your key using 'chia wallet show' to see rewards for each key

What do you mean by open port 8447 on the main node? I’ve disabled the firewall. Is there something specifically that I need to do to get Chia to listen on that port?

Yep I installed the certificated on the harvesters by running chia init -c to the certs path.

1 Like

Don’t disable the firewall. That’s not a good security practice.

Did you read this? Farming on many machines · Chia-Network/chia-blockchain Wiki · GitHub

One of the steps is opening port 8447 on your main node.

I know, I’ll deal with that later :slight_smile:

Yes I have read that like 6 times!

But how? I mean, I know how to open it on the firewall, but not how to get Chia to listen on that port. And that doesn’t seem to be in the docs as far as I can see?

I should add the harvesters and the full node are on the same network.

There are two parts.

  1. Opening it on your main node
  2. Giving your harvester your main nodes IP address

Opening Port On Ubuntu

Using ufw is one way to do that. Here’s a guide: How to Open Ports in Ubuntu (Guide) - sudoadmins

Giving Harvester Main Nodes IP Address

You need to edit config.yaml on your harvester computer. On the Farming many machines wiki, there’s this relevant section:

  1. Open the ~/.chia/mainnet/config/config.yaml file in each harvester, and enter your main machine’s IP address in the remote harvester's farmer_peer section (NOT full_node).
    EX:
harvester:
  chia_ssl_ca:
    crt: config/ssl/ca/chia_ca.crt
    key: config/ssl/ca/chia_ca.key
  farmer_peer:
    host: Main.Machine.IP
    port: 8447

Where Main.Machine.IP is the IP address on your network of your main node. Make sure you’ve set your main node to have a static IP address in your router.

Open Port 8444, a lot of times this is the problem