Harvester not conecting to Node after Chia update

Hi all,
my harvester running on a second machine is now not connecting to the main machine since i upgraded to 1.2.10
Getting this error;

AttributeError: ‘WalletPeers’ object has no attribute ‘connection’
Cannot connect to host ssl:<ssl.SSLContext object at 0x000001F3BB416CC0> [The semaphore timeout period has expired]
Any ideas?

Did you update harvester and full node?
They both need to be on same release.

Yeah i did. I have removed and reinstalled chia from scratch on the harvester with the latest release
Wont connect to the host now and getting this error;

harvester harvester_server : INFO Cannot connect to host ssl:<ssl.SSLContext object at 0x000002324AB89CC0> [The semaphore timeout period has expired]
2021-11-03T16:36:36.399 harvester harvester : INFO Reconnecting to peer {‘host’: ‘’, ‘port’: 8447}

Delete your ssl keys you created to connect your harvester to your main node and create new ones.

I’ve advised a few ppl to try that, and no one came back after looking for more help, so i assume it fixes it.

I’m using windows and I copied the CA folder from the host and installed via chia configure commands in powershell.
Should i delete just that CA folder inside the SSL folder which i believe contains the keys and then copy again and reconfigure?
Apologies for my lack of knowledge and thank you for your help!

I’ve as much understanding as you, I learnt to do it from a YouTube vid no need to apologise were all learning together, and I’ll be honest, I dont even remember exactly how the process was created.
But yes, that ca folder has the ssl keys that allow the 2 computers to communicate.
So I’d delete them and start over, I dont even recall how the key was created, but re doing that process will hopefully fix it.

1 Like

Same learning from youtube. I just tried deleting the keys from the harvester and re installed that CA folder from the mother ship host. Have the same error.
Will try deleting the keys from the host and restarting the node.
Been trying to problem solve this most of the day and its frustrating.
Was working perfect before the upgrade.
If i find the answer i will post

Yes, id delete the host key to and recreate it, but I’m not knowledgeable enough to know if it will just create the same key, I’d assume not.

Good luck.

I’ve decided to start with a fresh install on both machines.
24hrs to sync the node
Hopefully my plots are recognized and wont I need re-plotting.
Fingers crossed this works.
Thanks again for your time

1 Like

Definitely don’t need to replot!
If you have your mnemonic, your plots are fine, I can guarantee that much, unless you made some some spectacular f up.
And all you did was update its a pita but dont stress, you’ll get there.

Your welcome, my pleasure, enjoy ur day.

What is your source on that? I’ve been running different releases sometimes and never had an issue.

No idea, I believe it was info direct from chia themselves.

If you check your logs, sometimes you see that one side is whining that the other one doesn’t’ have the same software version. The warning is not really telling to much, as IMO should point to version discrepancy (e.g., me v2, you v1) and to exact node using its IP address.

With that said, we don’t really know whether those versions must match exactly, or rather there are groups of versions that can still work together without any issues. (It means, whether that log entry is there when something is not working, or rather when one side just sees that version discrepancy.)

I guess, this error/warning should be listed in one of those log explaining docs.

This is from chia github on setting up harvester.

“Be aware that major updates might need you to copy the new ca contents. Verify that the harvester does not report SSL errors on connections attempts.”


Looks like firewall issue. Check inbound rules for port 8447 on the node machine. I had similar mistake when updating on Windows, overlooked popup requesting to allow connections (and firewall rule is to block by default, unless explicitly allowed)

1 Like

It implies that modification to ca folder were made by the updater, as such known for Devs/QA. Should be really easy to put a mark next to the download link that it is a “major” update. It would just make our lives easier.

Thanks I’ll look into it. It would be great to have a thread with reports of issues pertaining to multi-machine setups and incompatibilities.

1 Like

Yeah I tried that and created new incoming rule for port 8447 on host mchine but still the same issue.
I just reinstalled chia 1.2.10 on both machines with same result.

2021-11-05T00:23:52.138 harvester harvester : INFO Started harvester service on network_id: mainnet
2021-11-05T00:23:52.138 harvester harvester : INFO Reconnecting to peer {‘host’: ‘’, ‘port’: 8447}
2021-11-05T00:23:52.169 daemon chia.daemon.server : INFO Register service {‘service’: ‘chia_harvester’}
2021-11-05T00:23:52.169 daemon chia.daemon.server : INFO registered for service chia_harvester
2021-11-05T00:23:52.169 daemon chia.daemon.server : INFO {‘success’: True}
2021-11-05T00:24:13.169 harvester harvester_server : INFO Cannot connect to host ssl:<ssl.SSLContext object at 0x00000190A4909CC0> [The semaphore timeout period has expired]
2021-11-05T00:24:16.184 harvester harvester : INFO Reconnecting to peer {‘host’: ‘’, ‘port’: 8447}

Scratching my head to solve this one.

I found the issue in the windows firewall.

1 Like

Have you tried a .9 full node with a .10 harvester?

I’ve set this up today, telnet works, so connection good, but harvester will not show.