Have you forwarded port 8444 via your router to your primary farmer yet?

I am pretty sure uPNP is working on my router but just in case, I forwarded port 8444 to my farmer machine. You have to do this through your router’s web interface, my fiber router is from AT&T and its NAT page for port forwarding looks like this:

I added a custom service named “Chia” which requires port 8444, both UDP and TCP, then I selected it:

  • Service: Chia (port 8444)
  • Needed by Device: IP of farming computer (

There’s a nice website that lets you verify that a port is open:


When I open that webpage from my farmer machine (the one running the Chia GUI), it looks good, I checked port 8444 and it looks open:

If I enter some other random port like 8445 it returns NOPE, so things seem good?


I just did this earlier this week, I thought uPNP had it all taken care of, then found out the port was blocked actually.

We have TP-Link Deco mesh routers in our house, they have a limited app for managing things but luckily port forwarding was nice and simple


There’s no need for UDP, port 8444 on TCP is enough.


yeah, upnp usually causes more problems than it solves. why you would want software to “automatically” expose ports is beyond me. The reason any router worth it’s salt disables this by default is to prevent you exposing yourself to threats “inadvertently”


Did this recently too, after checking with some tool online. My farmer is behind 2 routers actually, so I had to set up forwards on both. Cable company router forwarding the port to my second wifi router, and then from there to the target machine. It changed how quickly and how many peers were connected and increased comms in the logs.

1 Like

Struggling with port 8444…can you advise here please?

  1. Not sure which LAN IP I need to put
  2. What LAN IP (is it my network IP address or smth diff)?
  3. Public/Local port…

The lan ip is the internal address of the computer you have inside the network running the full node… i.e. or, finding it depends on your OS… you may have a list of them in that Device drop-down where it might fill it in for you. the ports 8444:8444 is correct.


Ok, I put my machine IP address, but how about Device? shall I add the device somehow too? (still cant find an option how to do this though).

Just talked to my ISP and they said they don’t block any ports - all open but Open Port Check Tool - Test Port Forwarding on Your Router says it is closed.

Does it let you submit without filling in Device? I thought it might be a list of your internal devices (i.e. your machine would be in it) to auto fill the lan ip.

not really…with a list of devices you can simply add devices, without specifying IP but my macbook wasn’t on a list so had to do manually.

no, I don’t. I’m farming from my company network so there is nothing I can deal with the IP or Port.
Just start the GUI and let it farm.

this port should be open for my farming machine and her IPv4 address which can be found via cmd → ipconfig ??

yes, you can also “reserve” or set that internal ip in the router. useful if the machine turns off and when it comes back on it is not given a new ip but the same internal ip you have set the 8444 port to.

interesting, how is this function called please? can’t find anything with ‘reserve’ in my router settings, shouldn’t it be done in the machine config not the router? :thinking:

@juicykrypt555 was under advanced > dchp settings > – option to reserve mac address to ip’s

i have 6 pc’s on my network so it was useful to me…

nice thanks, I just found it and assigned my mac address to the current IP, but for the port forwarding I’m facing a problem my router (Asus RT-n10) doesn’t seem to have port forwarding, I could find only port trigger function or virtual server… none of the seem to work… I also contacted my internet provider to open the 8444 port with the ip address but they said it’s my local address so it can be done only via router… should I tell them to open the port also for my public ip address?

You shouldn’t need to contact your ISP for this.

See here for port forward instructions for your router:

1 Like

I tried this already yesterday and it didn’t work that’s why I decided to contact them…now I also tried the Simple port forwarding program but it set it just like I did… the port just won’t open… I have a cable connection from the main router to switch and then to Pc can the switch be a problem? I don’t know what to do and my syncing is trash… few times a day it gets No sync then after an hour it is ok again… also tried to add the connection of the special nodes (introducers) but I could connect to only of them aw shit why they make it so complicated ?!?