Help With Farming on Raspberry Pi!

So for those who farm (not plot) with Raspberry Pi, how is it even possible? How have you gotten around the size of the blockchain (mainnet) files?

So I got my pi set up just fine with the 16gb SD card I bought it with, put Ubuntu on it, installed chia fine, all that jazz, but then I realized that the blockchain files have already exceeded 5 GBs and that I would need a larger card to store the blockchain files going forward since the linux /home directory is on the boot drive by default and I do not have the savviness to relocate it. It also appears that you cannot change the location that the chia program stores the mainnet/wallet files, so you’re stuck with it being in the default location on /home.

So I got myself a 512gb micro sd and have had much trouble setting up the pi. Frantic googling revealed that larger cards come in the exFAT file format, whereas the pi can only boot in FAT32 format. Well, the max file size of FAT32 is 4GB…already smaller than the size of the mainnet files.

So for those who are farming their already-plotted HDDs on their Raspberry Pi’s, how the hell are you doing this? What am I missing? Is there in fact a way to change where Chia stores the mainnet files? Am I stuck having to troubleshoot relocating the /home directory to an external drive? Or is chia farming on Rpi doomed to fail when the blockchain gets too large?

Thank you for reading all this.

1 Like

Pi is just a computer. Not sure why you’d choose exFAT or FAT32 to run Linux on, most of the world is on ext4 if they aren’t being overly creative.

Plenty of options for putting the chia files on a different drive. Mount a drive on /mnt/home copy the existing files to it, the put it in /etc/fstab as /home and reboot. Mount a drive anywhere and symlink ~/.chia to it.

Nothing here is “doomed” in anyway.

A good guide to move home to a different drive.


SD is very slow, why not use raspberry directly with ssd for the system?

It took me about 10mins to use rasberry imager on the 32GB-card, I had laying around and install chia.
Then I had to wait 2 days for sync, cuz I thought, I couldnt copy DB from Win to Ubuntu.

No magic :grinning:

farming on Pi? how many hdd linked to the Pi ? what cables used to link them ? are they internel drives or externals ?
what is the power unit used for that ? can you guys help us ?

I started with a bunch of external USB-drives
and when I ran out of power-sockets, I bought a 4bay-enxlosure from Icybox.

Its hard to say, how many devices are supported, but id expect something between 8 and 16.

I had the same issue as you, my blockchain file was 5GB and taking up a chunk of drive space. I switched to booting (ubuntu server) from an external 240GB SSD connected by USB. Problem solved. Not gonna lie, it was a pain to set up as it a relatively new feature and my Pi4 needed a firmware flash to get this working, but apparently newer pi4s with updated firmware will support this out of the box.

With the proper usb adapter with UASP enabled, it has much better I/O performance compared to MMC SD cards as well, but meh. Actually, copying the blockchain db files from my plotting machine to the pi was noticeably quicker.

After initial sync, OS-drive stays pretty idle, so thats a bit sad for an SSD.
On the other hand, SD-cards all die rather soon in 24/7 usage.
I guess sooner or later i’ll have to upgrade.

Most pis probably run in SD-cards and its gonna be a funny week, when the size of the blockchain hits a certain lvl around 30GB… :rofl:

1 Like

Use what you have I guess, pulled my SSD out of an old laptop that was gathering dust in the corner, and dug out a really old 2.5" usb3 drive caddy. Someone else in another thread also correctly pointed out you’d be losing a USB port for the boot drive.

Back to the OP, not sure why you would have problems with a 512GB SD card. Doesn’t the filesystem (format) get overwritten when you copy the OS image on to it, shouldn’t really be a factor. My understanding is only the boot partition is FAT32, and the rest (home dir) is ext4. How are you copying the OS onto the SD card?

This is my boot SSD which was formatted and written to using the rpi-imager and gparted: