Hi, I have the following problem with an external hard drive

Hello, I will try to describe the problem briefly. I have an external hard drive that connects to usb 3 . When I transfer plots to it, I always get the following error. - Failed to open file I:\ChiaPlotsExt1\plot-k32-2021-06-10-10-14-6a3fc10a029e0f92903c07408811c791e6993c77c515a69786875af870d00e33.plot. Invalid plot header magic Traceback (most recent call last):
File “chia\plotting\plot_tools.py”, line 189, in process_file
ValueError: Invalid plot header magic
I want to say that the average transfer speed is about 13,5 mb/s . The transfer takes about 2 hours .
I tried the following file transfer options. - copy , cut , direct ploting on ext drive . conver partition from exFat to NTFC , Working chia gui , not working - same result . Always get that error .
If i back plots to internal HDD they are ok and not have error . That is so strange .
I really need your help. I can’t understand where the problem is and why this error occurs.
Тhanks in advance everyone.