How To change clock time in chia manually?

every pc I’m using has incorrect time data inside the chia app. all of my times list as 4/19 or 3/19 sometimes at best 5/19-5/20. is there some way to manually sync the clock inside the chia GUI? i have tried everything recommended outside of the app and nothing is working. if having the clock synced is such a big issue, why is there no way to manually adjust it?

Make sure your Time and TimeZone are setup correctly in the OS. Are you refering to the “peak time” in the gui? That is not the current time but the time of the last synced block in your node. It should catch up to the present once you get fully synced

1 Like

my computers have spent DAYS trying to sync and they never catch up. my listed time and date in Windows OS are all correct

Why will you not just copy ~/.chia/mainnet/wallet ( %USERPROFILE%/.chia/mainnet/wallet) from synced device to another-one?

At this point it is best to install the v1.1.6 client

i have already installed 1.1.6 2 days ago. didn’t help at all

i have not been able to get ANY computer i have to sync. the best i’v done is get my plotting pc to sync in a projected 28 hours… and then yes my plan is to copy the node and db over to my farming pc.
28 hours is too long to sync, others are doing it in seconds. there is clearly a bug or error occurring keeping people at disgustingly slow sync times. many folks say that my block being created on incorrect dates could be a hint that my clock is off and causing the syncing issues however i cannot find any way to manually adjust the chia app clock. all my other clocks including OS are in sync with global time

Is there more than 1 full node running on your network?

Yeah, why do you need that? Organize the harvester nodes.

do you mean more then one pc trying to sync? no currently only 1 pc trying to sync connected to farming wallet with farming pc shut down

can you elaborate a bit more? what do you mean by “organize the harvester nodes” ?
i need at least 1 pc to sync the wallet so that i can copy over the node to the pc that took 6 days to reach 311,000/315,000 because it clearly has an underlying issue that is keeping it from ever fully syncing let alone syncing at a reasonable rate.

1 Like

already tried every one of these remedy’s, thank you though.
he mentions in the beginning that these are for staying in sync and i have NEVER been able to get a node fully synced. syncing the OS and closing and re opening chia did not help, regardless i genuinely do appreciate your efforts. there just doesn’t seem to be a way to sync the clocks manually

The clock inside the GUI app shows the time that the most up to date peak was made so if your system is not in sync it won’t show the current time. Even when it is in sync the clock will be a little behind (up to 3 minutes behind in my case).

Just outta curiosity what are the specs of your PCs? I used to try to farm off a Celeron N4100 system and that thing took over 2 days to sync but when I got a hold of a much faster Ryzen Embedded V1605B system it synced in just 24 hrs. Also I’d only run one full node on a single network at a time and have the other systems only do harvesting so that they aren’t all trying to connect to the Chia network at the same time (which can cause many issues.
Follow the guide here on how to set that up: Farming on many machines · Chia-Network/chia-blockchain Wiki · GitHub

Any news? I just start plot and harvest and my sync is too slow. Have some connections and they are all 0/0. Just 2 of them works one is wallet just going up and other peer going little bit down. Introducer not working either. I saw time is not right on gui and was thinking about maybe this is the reason but it seems Peak Time is not show current time…

8444 port open,
Upnp disabled throu router and config,
Have static ip,
Checked Windows time million times and sync,
All firewalls (windows and router firewalls) disabled,
Added firewall rules for inbound and outbound,
CPU I7 6700k 4.00GHz,
Win 10 with all updates,
16gb ddr4 ram

But still getting 0/0 connections and not fully sync more then 24 hours

Also debug just gives this error;

    2021-05-31T01:07:00.385 full_node chia.rpc.rpc_server     : WARNING  Error while handling message: Traceback (most recent call last):
  File "chia\rpc\", line 212, in safe_handle
  File "chia\rpc\", line 200, in ws_api
  File "chia\rpc\", line 161, in open_connection
ValueError: Start client failed, or server is not set