How to get full space on HSMR drives

I bought a “Seagate 18TB Exos X20z SATA 3.5” Enterprise HSMR HDD 7200K RPM ST18000NM013J" through ebay. It is an 18TB HSMR drive capable of 20TB when accompanied by the appropriate configuration and software. I mainly got it because I needed an 18TB drive to migrate plots to while replacing a bad drive in one of my stripe sets. That is now done and the new HSMR drive is empty again. I would like to see if I can get it to work at its full capacity.

A quick google does not tell me much. I was told by another that it is a Linux only function and even then, I have no information on how to get it to work.

Anyone have some good links to look at?

This drive was $230. At that price, the 18TB capacity is a good deal but if I could get the additional 2TB, that would be a great deal.

1 Like

I have several of those drives, still waiting for how to get that extra space out.

1 Like

How can we get these in the UK?

Those drives, at least for now, are not meant to be sold to general public. Most likely they are being sold on eBay as hyperscalers either rejected or overbooked them. What it means is that at least for now Seagate denies that those are on the market and is not sharing any info / software (e.g., to up-format to 20 TB) with individual buyers. (I have called Seagate and got nowhere - “bad” serial numbers.)

If those drives are rejects (e.g., HSMR doesn’t work as promised (high data corruption rates), or have higher failure rates), the problem is that they don’t have any warranty, so potential issues are on us.

So, either someone from those hyperscalers will “leak” the software, or we will need to wait for HSMR drives to be generally available.

Although, it may be that chia farming is a niche HD market, where we don’t really need to write to those drives more than once, so we will not face any of problems that hyperscalers may see.

1 Like

From what I have read, people suspect that the batch on ebay (which is where I bought mine from) is a stolen batch of drives. Yes, there is no warranty. But it did have a 30 day return. I figured if it was good when I got it, I would be fine. And I have already written and then pulled off a complete batch of plots from that drive. So it’s good.

Well, if anyone comes across any software/drivers in the future, they can post it here. I will spend a little more time looking for something and then I’ll just fill it with plots. I can always move the plots off later when the tech become available.


The red flag on purchasing those particular drives is the simple fact, that on ebay, there are tons of them offered up (why is that?) from various sellers (again why?) and they are cheaper than almost any competing similar product.

They must be cheap for a reason… could be stolen, could be failure rate, could be poor performance…could be they actually can not be reflashed to 20TB or …just total lack of significant warranty (using that term loosely as Seagate disowns them) or almost anything…pick your poison.

Is the small discount over any legitimate drive really worth it? I can buy actual 20TB Seagate referbs (that are 20TB formated) w/2yr warranty for $50 more, so I say definitely, NO!

1 Like

Your input on how to use an HSMR drive to its full potential was very helpful … :face_with_raised_eyebrow:

1 Like

I will meet your toxicity with toxicity. It is unwelcome here.

sudo pacman -S btrfs-progs
sudo mkfs.btrfs -O zoned -d single -m single /dev/sda

want more drives in one pool?
sudo mkfs.btrfs -O zoned -d single -m single /dev/sda /dev/sdb

You will be in zoned mode.

Note → did I say you could use these in windows? no. I specifically did not. Did I say you could use these in ubunut, maybe but you need a recent version of btrfs kernel moduals, might have to compile. I specifically mentioned arch because it works out of the box.

1 Like

That wasn’t toxicity, it was sarcasm, not the easiest thing to do in a text based environment. Sorry it was mis-interpreted. Can’t anyone just have some fun around here?

You didn’t specifically mention anything, you just started spitting out command lines with no explanation.

Are you saying that with Arch Linux, with that type of formatting, I would be able to see the full 20TB of storage on this drive? I’m not going to try to pretend I know that much about file systems in Linux. I have used linux for years for multiple projects, but never really that deep into the file systems.

Looking further, I do see that the “Zoned” feature has to do with “Host-managed zoned mode”. That may be where the confusion is (your confusion or mine, not sure which yet). From what I understand, this is not a “Host” managed drive. The HSMR is “Hybrid”, not “Host”. But I may be wrong. Maybe that clarification is where I should start. Is this a Host managed drive or a Hybrid SMR drive? Once that clarification is set, we can work on what solution may be available to access the storage space.

#Everybody uses windows or you can’t see out side!!! :rofl: :rofl: :rofl: :rofl:


Found the manual for the drive. Not the exact part number, but same model name. It does list “ZAC Host Managed zoned device”. So I’m going to start looking into the Host setup. But need to get a bare metal linux box up and running for testing.


If you format it without zoned mode compatible filesystem it will be in cmr managed (but not host managed) mode. So you get less space.

You need a recent version of btrfs progs to do this. This is the important part.

Specifically from that page Since version 5.12 btrfs supports so called zoned mode.

Whatever (Linux) operating system you use will need to get that version. If your package manager gives you an older version you must compile a newer version. Arch is a rolling release so it will pull 5.17. don’t want to use arch? Compile recent btrfs then. No problem. This will not work in windows even if you use the windows btrfs progs.

I have 37 of host managed drives btw. $9.50 /TB xDDD

This is a tip from my real world use case → You also need to set your io que depth to 1 or a bug in the firmware will case the 14’s to start giving IO errors. (this is why they are showing up on eBay).

Tip 2 → they will take longer and longer to mount the fuller they are. Btrfs 5.16 dramatically reduced this, but a fully plotted 14TB hm drive takes 1 min 45 sec to mount. A 18 takes 2 mins and some change. You will mentally think there is something wrong however it is fine. This is a btrfs wide issue but dramatically worse on hm smr. A full controller managed (regular) will take 10 seconds.

I have a script at reboot to mount and set the que depth with hdmarp (sudo hdparm -Q1 /dev/sda) I don’t use fstab because it will start a race condition sometimes. Let me know if you need this.


When I run “modinfo btrfs | grep -i ver” on my Ubuntu 20.04.01 system, It says “vermagic: 5.4.0-122-generic SMP mod_unload modversions”. Is that saying it has btfrs 5.4.0 on it? Isn’t that sufficient to meet the “Since version 5.12” requirement?

This is just a curiosity at the moment. That Ubuntu system is running on Hyper-v so I can’t do the testing I want to on that setup. But if this is sufficient, it will make it so I can use Ubuntu on the test system keeping my environment familiar (and the Chia instructions accurate that I normally follow).

Some distros split btrfs-progs and the core modulals. Please install btrfs-progs or something very similar to this and run btrfs-progs --version or something very similar to this.

I will be back tomorrow to help anyone who needs it. Goodby.

So where is the download link for the formatter windows version to get that extra 2 TB??

You cant use it on windows, full stop.


Good to know about queue depth 1. I worked around this with an old PCIe x1 card that’s probably too dumb to understand queue depth. Once written, they seem to work on any port read-only.

I’d be curious to see your mount script. I’ve been using “noauto” in fstab and running a mount script via systemd to mount the drives once the system is up (Fedora 36).

It’s literally a chain of

sudo /bin/hdmarm -Q1 /dev/sda
sudo mount /dev/sda /mnt/btrfs01
…(all drives)…
sudo /bin/docker start chia

The issue is these drives take >2 mins to mount each once full so you will get timeouts and chia client won’t scan for a while.

I’m not an expert but this seems to work pretty well.


So, really not much different than what I’m doing, but with the hdparm piece added in. I do start my harvester before the script starts mounting drives, so as they come online, they are added to the harvesting (default refresh timers on chia). Allows things to start spinning up without having to wait for those slow drives.

Are you sure this drive is the original Seagate Product? Many people are selling non-Orignal products on eBay. I purchased and installed Seagate ST1200MM0008 and it is working fine for me.