How to start CLI ubuntu

I installed chia using the experimental GUI installer, now I wuold like to make something by the CLI but I am getting crazy I dont understand from what path I have to run that.

thank you

If you run this command it should find all files names chia:

    cd /
    sudo find -name chia-blockchain

I’m not a Linux expert but hope this gives a starting point at least.

I found this Binary CLI tools can be found in /usr/lib/chia-blockchain/resources/app.asar.unpacked/daemon/
but when, for example, I try to type chia plots -h
it says
Comando «chia» non trovato, si intendeva forse:

comando «chi2» da deb paml

Provare: sudo apt install

I think the chia command is under /usr/lib/chia-blockchain/

Can you try

cd /usr/lib/chia-blockchain/

and try running the chia command there ?

1 Like

cd
cd chia-blockchain
. ./activate
chia init

2 Likes

the rusult was:

sudo find -name chia-blockchain
find: ‘./run/user/1000/gvfs’: Permesso negato
./usr/share/lintian/overrides/chia-blockchain
./usr/share/doc/chia-blockchain
./usr/lib/chia-blockchain
./usr/lib/chia-blockchain/chia-blockchain
./usr/bin/chia-blockchain

however in cd /usr/lib/chia-blockchain/ if I try:

chia plots -h
Comando «chia» non trovato, si intendeva forse:

comando «chi2» da deb paml

Provare: sudo apt install

Yeah, like @Mugen0815 said we have to run

. ./activate

when inside the chia folder. I forgot that bit

1 Like

ooo I didn’t try that
Can i do that also if chia is running already with gui? :thinking:

thanks

nothing :woozy_face:

:/usr/lib/chia-blockchain$ sudo . ./activate
sudo: .: comando non trovato

I’d try it without sudo.

I’d also try to install it via CLI. It’s really much easier: INSTALL · Chia-Network/chia-blockchain Wiki · GitHub

Just run the commands one by one, This way you have full control over where you’re installing.

You can also create separate folders for each version so if something goes wrong you can simply revert to previous version.

1 Like

I did already with no sudo.
But I don’t wnat install it is already installed with experimental GUI installer.
In that document it says "Binary CLI tools can be found in /usr/lib/chia-blockchain/resources/app.asar.unpacked/daemon/" but how I sayd it doesn’t work

you are suggesting me to install it by CLI too?

I think you’re right about the path. I’ve found this https://pythonawesome.com/a-cross-platform-plot-manager-for-chia-plotting/ that mentions the same path

Linux Example: `/usr/lib/chia-blockchain/resources/app.asar.unpacked/daemon/chia`

Maybe try . ./activate in that path. Other than that I don’t know what would help.

Hope you resolve it as it can be frustrating. Good luck.

:/usr/lib/chia-blockchain/resources/app.asar.unpacked/daemon$ …/activate
bash: …/activate: File o directory non esistente
nothing :grimacing:

So It is better uninstall and do it again but the CLI?

Its dot space dot slash activate

I had already tried, nothing same result :woozy_face:

Then I can only recommend to dump the experimental GUI and use the cli, as @durin recommended already :frowning:

try to launch CLI like this ./chia

Here is what worked for me:
cd /usr/lib/chia-blockchain/resources/app.asar.unpacked/daemon
./chia -h

after you have changed the directory, you just need to start the comands with “./”, for example, the wallet info:
./chia wallet show

1 Like

There is no activate file in Ubuntu 20.

for OS greater than Ubuntu v18, try ./chia plots -h
No need . ./activate