How to update Chia Gui?

I’ve been running my Chia GUI/Full node of version 1.2.0 since like last year, I hesitated updating because people were encountering many issues so I didn’t bother up until now.

I am running Windows 10 64-bit.

Should I update my Chia GUI or just stick to what I’m running? (If so to what version?) and how do I update the GUI?

Here’s 2 Issues that I found out when updating. I don’t think it may be as simple as downloading the latest executable and running it, or do you rather uninstall your current GUI and then install the new one? I am trying to make sense of all of this before updating so I know what to do rather than get stuck in the muck midway. I will be referring to the ff: files

A.) Chia Database File
Location: C:\Users\PCName.chia\mainnet\db

B.) Wallet File
Location: C:\Users\PCName.chia\mainnet\wallet

1.) How do I know if I need to update my Chia database file and my Chia wallet database file and how do I update these?

Users pointed out that there seems to be a transition in the version of the Chia database file from V1 to V2 when updating, however one user denied this happens. After updating the Chia GUI, is it necessary to update the database and wallet files? If so, how do you do this?

2.) If I cannot connect or sync my Chia full node after updating, what should I do?

I also haven’t tried the Chia CLI yet, mainly because I don’t know how to access it.
Any help would be appreciated.

The only issue that I’m running into is after running the Chia GUI for a week, it will then turn nothing but white. I am not sure if the program is still running or if I am still earning Chia when it does that, but the only remedy I can do after that is restart the computer and restart my Chia GUI.

If the screen goes white for more than a few seconds, get that taken care of (reboot or restart Chia). You might be losing sync, not farming, or have a crashed plot if you are plotting - no way to know, crashed is crashed.

  1. Check the mainnet\db folder and look for files that either have v1 or v2 in the name - that should tell you which one you have. There are update instructions online (and youtube) but I honestly find it easier to delete it all and fresh install + resync V2 with the latest Chia wallet. If you have a second computer you can install there, then back up the v2 blockchain to move over to your farmer and only have it down 10 minutes instead of a couple days.

  2. Save your passphrase and back up the database and wallet files before doing any of this. They can be pasted back in if something gets corrupted. Worst case you can delete the wallet folder contents and db folder contents and sync it all again - usually it fixes sync craziness or wallet not opening.

Oh, and I usually uninstall Chia first then install the new one. For some reason it doesn’t respond well to just trying to install the newest version (at least it didn’t last time I tried).

You definately want to to upgrade, we had a hard fork, see here.

If i were you id also convert db to v2, see here.

I think .5.1 is the latest full release but possibly has some issues, so maybe try .5.0
Personally im still on .3.3 with no problems.

I never uninstall and just shut chia down then install the version i want.
I think one of the latest .5.2 maybe asks you to uninstall with a popup, but as i said earlier i wouldnt go that far as there are some issues need fixing possibly.

Once you have updated gui and converted to v2 id delete your wallet db and let it resync, then once thats done, will be fast, check your pooling info, payout addresses to make sure they didnt change as sometimes happens.

Edit.

Thsts just a visual error, mine did it once , pool payments continued coming in as expected.

3 Likes

Only the app turns white, but not my entire OS/screen. I checked if I am receiving XCH on my wallet and indeed I sure am even during the time it turned like that.

1 Like

Currently, both my db and wallet files are v1 on Chia GUI version 1.2.0.
Yeah I think I’d rather start from a fresh install rather than trying to update from existing. I have a feeling that it may cause issues. With your suggestions + Bones below, I’d be able to convert the db from v1 to v2.

1 Like

If anything doesnt go as planned just post in the thread.
No point worrying about what could not work when it probably will.
Good luck.

1 Like

I have this sometimes to, usually you can just click view->restart in the Chia app and it will relaunch the graphic interface. Ordinarily, the farming processes should be running fine in the background

1 Like

I uninstalled v1.2.0 and installed v1.5.0.
I downloaded v1.5.0 from: Release 1.5.0 · Chia-Network/chia-blockchain · GitHub

The first thing that comes up is asking me to migrate my keys to a new keyring that is secured by a master passphrase. Should I do so? Will this affect my 24 word seed phrase in any way?
G1

I think this is equivalent as metamask’s password feature, where it only protects your seed from an intruder who would compromise via physical access to your machine?

No, the passphrase is just local for that machine. I don’t think it’s particularly useful since the keys are still easily accessible as long as Chia is running. But well, it doesn’t hurt either

3 Likes

Ok I made the strong passphrase. The program sort of forces you to, because it won’t allow you to “create new keys” or delete existing ones.

Anyhow, I am not sure what goes first - (a) Run the program and wait for it to fully sync or (b) update the database file from version 1 to version 2.

I’m currently starting (a) over (b) and waiting for it to sync, just like what this guy did:

From time stamp: 3:45
I assumed he fast forwarded it.

But I feel I might be wrong and that you should only do one of the 2 options. I can see that the database file is constantly being updated as the GUI is syncing. If I did (b) then I wouldn’t need to do anything else…

Where do I see this? I cannot find it at config.yaml

Pooling info is viewed on the nft you plotted to , on .3 3 its in the pool tab, the pool payout address is also vsible on the nft.

Other payout addresses can be viewed on the farm tab, 3 verical dots on the upper right, click them, then manage farming rewards.

1 Like

My pooling info is correct, however my plots currently are not showing up (Number of plots = 0). Not sure if I should finish the syncing for them to show up. I didn’t move my plots at all, as I only intended to update the Chia GUI/Full node.

Once I am fully synced, can I delete the old v1 db and the old v1 wallet files?

Plots wont farm till your synced , so wait till thats done then see if its still an issue.

Being as you uninstalled then installed you may need to re add your plot folders.

You can if your syncing the v2, if your syncing v1 youll need to do the conversion to v2 before deleting them.

You say youre doing a)

So do the conversion before deleting them, or all that time syncing is wasted !

Then after its done, delete the wallet ( only the wallet, not the blockchain ) v2 db and let that resync. Its very fast.

Then check your pooling info and payout addresses, youve done that already which isnt what i advised, do that last.

1 Like

Ok one more thing is I noticed that my xch_target_address doesn’t match anymore (thank goodness this thread helped me a bit). I was able to compare my old config.yaml file and my new config.yaml file.

What is the difference between farmer reward address and pool reward address?
Should they always be set the same? (As I am seeing them the same right now).

Back then I remember this only being one address where you receive all the rewards If I am not mistaken. I have been simultaneously self pooling and pooling at the same time, but I believe I was using the address to receive rewards.

It tells you what they do in the popup box manage farming rewards… so read there.

I set all mine the same, so yes thats fine.

Pool reward address is where the .25 goes i believe, the other , farmer reward address is where the 1.75 goes on old non nft plots iirc.

These 2 addresses were always there iirc, thats why rewards came as 1.75 and.25 seperately.
Certainly since they made nft poolable plots.

1 Like

I guess I cannot upgrade my chia db file. I am getting this error. I guess I am stuck with a.) Let the program run until its fully synced.

I am not sure why Chia GUI v1.5.0 is telling me its expecting a “blockchain_v2_mainnet.sqlite” file, when I expect it to upgrade my blockchain_v1_mainnet.sqlite to a blockchain_v2_mainnet.sqlite file…

I’ve double checked and the db file is placed at the correct directory…
C:\Users\Phantom\.chia\mainnet\db

Or maybe v1.5.0 is designed to upgrade blockchain_v2_mainnet.sqlite to a higher version, and I essentially missed my chance to ditch a.) Let the program run until it is fully synced. I would need an older version of chia GUI to do it (perhaps v1.3.3).

Firstly, did you let it fully sync?
Secondly, what size are your current v1 and v2 blockchain databases?

No, v2 is the highest version afaik.

1 Like

Its not yet fully finished syncing
my v1 size is 146GB
my v2 size is 1.25GB
I read that v2’s final size will be smaller than v1 as a benefit, from your article.

If I am not mistaken, if I let the program fully sync, then there’s no need to do chia db upgrade command and I can delete the old v1 database file after its done syncing.
But since the program won’t allow me to upgrade my existing v1 database file, my only choice is to let the program fully sync all the way.

I’ve tried moving the v2 file to a temporary folder and then running the chia db upgrade command, but it yielded me that same error that I posted as a screenshot.