Hpool auto update plots

hi guys, so im running madmax + Hpool and my new plots created is not being sync. with the hpool, as you can in the terminal windows in the lower left side its says; capacity; 74.27 TB… even when i have made 5 more plots, it is still the same. BUT when i close the terminal windows and restart it with (./chia-plotter-linux-amd64), then it will update and show the correct


Check your config.yaml for the option scanMinute: X, with X as number of minutes to scan for new plots and the option scanPath: Y. Yozu should set scanPath: true and X to a valid number else than 0. If you set X to zero, the client will only scan on startup as in your case.
I had it set to scanPath: true and scanMinute: 5 so that the miner client scans every five minutes for new plots in the defined directories.

1 Like

THANKS, another question i have is that someone in the forum told me that i should run the proxy from hpool… but i haven’t use it yet… is it a must to use the proxy

Has it fixed your issue?

You only need a proxy if you run multiple hpool farmers behind a single public ip.
But I wouldn’t run a proxy unless you’re running more than three farmers on the same local network.

1 Like

Screenshot from 2021-07-07 14-27-42

like this … i have set it to 10 min…is it correct

i only have 1 pool, so t think that im good for now

How was is set before? 0?

1 Like

it was 0 before and i have changed it to 10

1 Like

now when i want to open the hpool miner i get an error

Because you set: ScanPath: false

1 Like

i have changed it to true… but still nothing


language: cn / to / language: en

1 Like

can you please verify that the folder is correct… i have chnaged it to en… still nothing

yes i was wrong… it works now… thanks

1 Like

any idea why i get this error…

Read error is when plot file “in use/locked”. Closing the program that uses the file would change that.

i have no other program running beside madmax and hpool… oh maybe this is the file being gererated…?

For example, if you copy one plot file from one directory to another (if HPool is running), you cannot move it. HPool is using it. Closing HPool frees the plot file.

1 Like

This are almost normal errors that everyone of us gets. I’ve asked this in another thread and others said they’re having also some of this messages. It doesn’t affects farming as after this message the connection to hpool is reestablished.

1 Like

ya sure, but i have set the hpool to update every 10 min… so as you can see the plot file that is beeing generated is also being used at the same time… i mean that is what i think for now…