I can't move .chia folder to another disk: Cannot connect to host


If I move the .chia folder to another disk, the GUI/node can’t start. When I move it back to the original folder, it works.

I did this:

  1. Create a symlink: mklink /J C:\Users\aitor.chia D:.chia

I also tried with another disk, and only with the /db folder, but every time I move the database or chia from the original installation disk, it doesn’t work.

What I’m doing wrong?

Windows 10, all updated.
Chia 1.2.11
I also tried with firewall off.

Thank you.

What size is your windows C: drive? I use a 500GB SSD to keep my stuff simple.

250 GB. It’s already full, that’s because I need to move chia to another disk.

What do you have installed on your C: drive? I only have CHIA and windows.


I’m farming in my main PC, so I have all kind of apps.

Without going crazy, have you thought about another machine for CHIA only?

Ebay has all kind of deals on Dell machines.

No, thanks, no more money.

Did you update the config file to tell chia of the new location?

The command to create the junction doesn’t look right.

What about this?

mklink /J C:\Users\aitor\.chia D:\.chia

To test after, run:

cd .chia
dir mainnet\db

There should be no errors after typing any of the above commands, and after typing the dir command, it should list the blockchain DB files.

No need to update chia config since you created a junction to the folder.

Have you opened up your file manager and double-clicked your junction to confirm that it is showing you the target directory’s files?

“mklink” also supports a /d option.
Aside from the properties showing one as “JUNCTION” and the other as “SYMLINK”, they appear to behave exactly the same way. But if you cannot get your link to work via /j, then try /d.

If all else fails, I suggest that you make the link again, and for the target, spell out the fully qualified pathname.

Why symlink?
You can just tell the chia client to look for the db (both blockchain and wallet db’s if wanted) on the other disk.
Check this for instructions: https://spacefarmers.io/wiki/guides/farming/movedb

1 Like

You can try an alternative method, where you modify your config.yaml (I use this one). Here are the changes you need to do:

  database_path: D:/chia-db/blockchain/blockchain_v1_CHALLENGE.sqlite
  peer_db_path: D:/chia-db/blockchain/peer_table_node.sqlite
  database_path: D:/chia-db/wallet/blockchain_wallet_v1_CHALLENGE_KEY.sqlite
  wallet_peers_path: D:/chia-db/wallet/wallet_peers.sqlite

Just make sure that the leading spaces fit what you have in your config.yaml and when you swap for your drive/path use forward slashes.

The advantage of this method is that if you have resources, you can put various folders from your mainnet on different drives (e.g., separate blockchain db from wallet db traffic or move logs to a slower drive, as logs can actually interfere with blockchain/wallet db access during dust storms (create more strain on the underlying drive).

1 Like

Thank you people for all your help, but I already tried all before posting here and anything worked:

@chiameh I did it the same way, it works by CMD but the node doesn’t start:

 El volumen de la unidad D es Trabajo
 El número de serie del volumen es: DEEF-F1A4

 Directorio de D:\.chia\mainnet

22/02/2022  15:10    <DIR>          .
22/02/2022  15:10    <DIR>          ..
22/02/2022  15:01    <DIR>          cache
22/02/2022  15:16    <DIR>          config
22/02/2022  15:09    <DIR>          db
22/02/2022  15:09    <DIR>          log
22/02/2022  15:09    <DIR>          plotter
18/11/2021  00:21    <DIR>          plotters
22/02/2022  15:24    <DIR>          run
22/02/2022  15:10    <DIR>          wallet

@seymour.krelborn the link it’s working from windows and also from cmd.

@xkredr59 I tried that first, but as didn’t worked, then I move to the symlink thing.

@Jacek I tried and doesn’t works.

Well, maybe you need to try harder :slight_smile:

Your output there just proves that you have your new directory structure on d: drive, but not that you made a proper junction on your c: drive. Create one more ‘test.txt’ file on your d:.chia\mainnet folder, and then try

dir %USERPROFILE%\.chia\mainnet\

If your junction works, you should see that new file there (as it will use that junction). If not, there is a problem with your junction.

When you try those changes to config.yaml, the best thing is to delete your logs, and when you start chia, check the new log for errors. Most likely, you did some error/typo when modifying config.yaml (had that problem as well).

By the way, when you try to use the config.yaml modification, maybe you can start with just one change:

  peer_db_path: D:/.chia/mainnet/wallet/db/blockchain/peer_table_node.sqlite

And, open file explorer on your d:.chia\mainnet\wallet\db folder. If it works, you should see there *shm and *wal files for that peer db.

The fact that UI doesn’t start implies that you made an error, and neither the old folders, nor the new ones are accessible.

1 Like

The link it’s done correctly:

22/02/2022 17:20 .chia [D:.chia]

I can see the file

C:\Users\aitor>dir C:\Users\aitor\.chia\mainnet
 El volumen de la unidad C es Sistema
 El número de serie del volumen es: 84C5-E2BE

 Directorio de C:\Users\aitor\.chia\mainnet

22/02/2022  17:54    <DIR>          .
22/02/2022  17:54    <DIR>          ..
22/02/2022  15:01    <DIR>          cache
22/02/2022  17:21    <DIR>          config
22/02/2022  15:09    <DIR>          db
22/02/2022  17:54                 0 file.txt
22/02/2022  15:09    <DIR>          log
22/02/2022  15:09    <DIR>          plotter
18/11/2021  00:21    <DIR>          plotters
22/02/2022  17:53    <DIR>          run
22/02/2022  15:10    <DIR>          wallet
               1 archivos              0 bytes

How big is the D: drive? And where do you keep your plots?

I’m trying now with that:

database_path: D:/.chia/mainnet/db/blockchain_v1_CHALLENGE.sqlite
peer_db_path: D:/.chia/mainnet/db/peer_table_node.sqlite

D drive have about 400GB of free space, I have plot in multiple disks.

Just do the change for the second one - peer_table_node.sqlite.

Before you start chia,

  1. remove all logs, so you will eventually see only new errors
  2. open file explorer over d:.chia\mainnet\db folder, so when you start it, two new files should show up (*shm and *wal)