I can't transfer my deposit from Hpool to Chia wallet

I transferred my deposit from my Hpool account to Chia wallet once (on last October). then I kept plotting more. now I want to transfer the rest of my deposit to Chia wallet again, but my Chia address is different than the previous one when I transfered the first time, and Hpool keeps saying that the new adress is invalid. should I transfer to the old address again? what can you suggest?

The chia wallet can and will use different public key addresses (receive addresses) that all belong to a single private key. Chia wallet accumulates all funds received on those addresses.
So, if you have/use the fingerprint/keys (and/or 24 word mnemonics) that went with your ‘original’ receive address you can use your ‘old’ receive address for Hpool. That ‘old’ receive address is not gone and still part of that chia wallet.

On the other hand, if you have a new wallet and receive address because you set up a new set of keys/mnemonics having lost the original ones…

Just curious as I never used Hpool, but can’t you set a new receive address in your account settings? I can imagine Hpool checking transactions for changes in receive address but you should not be tied forever to just a single one. What if you did loose original mnemonics…

3 Likes

Did you use the copy address button as opposed to manually copy pasting?

A simple space before or after the key would more than likely trigger that message.

Has that new address received coin before? Maybe hpool scan the chain to see if its a pre used address.

3 Likes

Maybe not. If they would do that, potentially a lot of people would be talking about this problem. I think that your suggestion about the extra space, or missing char is the key (the simplest test is to check the number of chars, what I think they do).

Another possibility is that to prevent potential fraud, they are not allowing for address changes, but then why the UI to support it. If that is the case, maybe one needs to contact them to make address changes.

2 Likes

Indeed, I think that’s less likely than a wrongly copied address.
Was just a thought.

The fact that hpool allowed them to try and change it and the invalid address msg leads me to believe it should be possible to change though.

2 Likes

The fact that you need to struggle with HPool to xfr your XCH is another reason for me why no one should use it, though.

1 Like

Very englihtening. Thanks. I am still using the same key so from what I understand, I can withdraw my deposit to the same old address. Yes, I can set a new key for Hpool, but none of them is valid as I tried.

1 Like

I always push the copy button. I pasted they address exactly like this way. No, I have used only one address for withdrawing my deposit.

I’m actually leaving Hpool completely. I’ll keep farming from Chia only. since it automatically withdraws everything to my wallet, it’d be the best choice to avoid any future circumstances.

1 Like

Yes you can. If you want to check first for peace of mind you could go to a faucet and have some mojo’s send to your old (not really;-) address and see if those come up in your wallet, official chia faucet is at https://faucet.chia.net/

1 Like

I’ve been using Hpool since June with no issues. It’s interesting that there was FUD back then and there is people posting FUD even today, but Hpool’s netspace share tells you where the smart money is farming.

I’ve switched addresses a few times without issue so not sure what could be the problem. You can withdraw a tiny test amount to ensure you will still receive it to your old address.

Hpool’s Official Discord Server: Hpool

1 Like

I tried to withdraw my deposit to the same address previously. It’s been “Auditing” for 7 hours now. I can’t revoke my order either.

https://www.hpool.com reports ‘maintenance’ at this moment (19:53 CET) so maybe…

1 Like

And just received a reply from them that it’s a normal time

1). Generate a new address at Chia
2). Delete the saved address at Hpool and set up this new address
3). Request withdraw