ISP won't allow port forwarding (8444)

Hi all, I’m in Mexico and have an ISP (Totalplay) that uses a shared IP address for everyone on the network. Because of the way its configured I’m not able to open up port 8444, which I believe may be part of the reason that I’m not staying synched. I’m wondering if there is any alternative. Obviously staying synched to the network is the most important long-term challenge.


You could try increasing the number of outgoing connects in the config file (target_outbound_peer_count). The problem with depending on outbound connects is that it can take a while for the node to find other full nodes that are accepting connects.

1 Like

another alternative may be to pay a little extra to get a “static ip” from your ISP, after which they should be able to let you port forwarding. at least this is the case in my country.

1 Like

You can try to open a ssh tunel to a vps then route your traffic via this vps.

1 Like

Thank you all!
I doubled the outbound peer count. Although this didn’t fix it I’ll leave it at 20.
My ISP doesn’t allow for static IP. I raised this with them before because I couldn’t connect via FTP.
I was able to use my VPN (Windscribe) to purchase a static IP through a data center for $2/month, which allows port forwarding.
Port 8444 is now open and I am synced! Will report if this doesn’t solve the overall syncing problem.

1 Like

@terragnosis Nice one! I am trying this out now and it seems to work like a charm. :+1:

It was a bit difficult to figure this one out but this is what you need on Windscribe:

  • An account (duh… :wink: )
  • Once you have that set up and paid for you can go to manage your account on their site
  • There’s a handy port forwarding tab that lets you sign up
    • Choose the “datacenter” option (there’s also "residential for $8/month but I saw no reason to use that)
    • It costs $2/month but you’re required to pay for the year, so it will cost you another $24 on top of what you already paid for the account
  • It takes a minute before you can manage your port forwarding
  • Then you should be able to do the following (I had to choose the location first, can’t change it now):
    • If you don’t have devices, make sure to connect to the VPN first while setting this up
  • Then once this forward is active you need to go into the app and change to that specific connection:
  • That’s it, go check Open Port Check Tool - Test Port Forwarding on Your Router - should be green now!

I have since learned that there’s more VPN providers that offer port forwarding, though I haven’t tried any of those. I probably could have tried this out for a cheaper price, for example:


Thank you, I’ve been looking for an answer to the same problem as well

i’ve won a few times now, and without ever messing with port forwarding. does opening port 8444 play a larger role in syncing up rather than winning rewards? thanks

@doink I have the same question!

Hope to find an answer at some point.

Maybe not throw them any money yet, this worked the first time I connected and I’ve not been able to connect and get an open port 8444 since then. I sent them a support request. :man_shrugging:

rly? I’m installing windscribe right now . I’ll wait your update.

Yeah, I uninstalled/reinstalled, but that didn’t remove previous settings, so I must have touched something and messed something up. :grimacing: I don’t know what it could be though so it’s a bit worrying.

For the depending on outgoing connections solution. I ran this way for a couple of days when I first started (by accident). I noticed that getting connections to other nodes could take a long time (it might go hours with only one connection). It would attempt to establish new connections but they would be rejected because the target node was already at its max. I found that deleting the peer table database helped a lot. It seemed to be trying nodes it had previously seen from this database. Deleting the database forces it to find new nodes to try which worked much better. Note: I only did this once so it may have been a fluke that it worked so well.

I need to post an update as well, the list from cyberwaters, i tried privateinternetacess and while they allow port forwarding, I can’t select which port, so I applied for a refund, going to ask the providers one by one about it first before jumping in

I’ve read somewhere that if you have a static IP then port forwarding won’t matter as much, or is that a full node, idk, but I’m looking for ways to port forward right now because I have a dynamic IP with my ISP…

Edit : I managed to get the port forwarded and I can use the portchecker and canyouseeme to confirm that 8444 is open now.

What I did was I disabled the uPnP option on my router and the port forwarding settings that are already there (I followed the guides on my router) suddenly works.

Windscribe continues too work to keep port 8444 open, but it has not solved the connectivity problem. I need to try @casualChia’s solution because finding no peers. More interested in finishing this round of plots first.

Ignore me!! (Sorry for the confusion @gborges1982) - of course when the Chia app isn’t running, there’s nothing to respond on port 8444… and then it says the port is closed.

So… All good now, port is open when connected to VPN as I described above!

I tried using your vpn but no luck.

@cultiv you can test if the port is open using this tool: Open Port Check Tool - Test Port Forwarding on Your Router (

@gborges1982 I can confirm that this has resolved my port open issue, but not the sync issue. There are other steps to keeping the port open, such as stopping the Firewall from blocking the port. I only got to the VPN as a last resort after configuring my router and every other possible step, since it was impossible with my ISP.

I just got off the phone with izzi here in MX with the same issue. Should I follow this path or is it preferable to change ISP provider?