Issue with U.2 SSD - WD GOLD 1,92 TB not visible

bought myself a sweet u.2 WD GOLD 1,92TB SAS drive only to find out I can’t really get it to work on my system. My motherboard is x570 AORUS ELITE. So far tried u.2 to m.2 adapter (over SAS cable), LSI 9341-8I and u.2 to PCIE adapter (over SAS cable). No luck. To be double/triple sure tested on two different machines too. Does anyone had problems with this particular drive or u.2 connection at all or am I the only one missing something?

have you tried through bios?

Also, make sure your BIOS is up-to-date.

1 Like

yup, it’s not seen under bios, nor LSI card bios. @WolfGT will do, doubt it’s that but sure will try everything

1 Like

What OS? So you can see the LSI card bios but when you look in it you don’t see any drive connected to it? Maybe a bad cable or the drive is bad.

How many other drives are connected to this system? Posting what your full system setup is like would be a good start.

Weird! Why wouldn’t the adapters work? That’s so odd.

it’s Windows 10, yup, I can look into LSI bios, though nothing to see there.

XD that’s my reaction after plugging in another one and another one

what’s the hook up like on the SAS is it data/power plug in one? or data and power separate?

its power through additional cable from SATA, combined into one connecting to SAS port in the SSD

Is your SSD drive SAS or NVME? Title says U.2 SSD, but the 9341-8i only supports SAS. (I lookup it seems that drive is nvme.

You said m.2 to u.2, do you mean SFF-8643 to SFF-8639? Normal SAS drive takes SFF-8482 or SFF-8680 (those won’t work)
What you need: 2260/2280 m.2 to SFF-8643 (this is a pcb with socket) and SFF-8643 to SFF-8639 cable

i’ll make photos of every adapter i tried so far and keep you posted

I have exactly the same drive in one of my servers (DL380p G8), this is a nvme 3.1 drive, so SAS won’t work. I am using this adapter and can use this drive without any issues: