Light wallet on Plotter machine

Hello farmers. I want to try the light wallet out. I have a machine where I installed chia only for plotting, it’s not farming or harvesting.
Would it break any plotting capability (I plot from powershell using the CLI commands) if I installed the light wallet there? I read it does mess up your farmer in this beta phase.


I’ve never tried it, but it’s not a farmer so can’t see an issue.
If it was an issue I’m sure there would be a warning about that also, and others would have had an issue by now and I’ve not seen anyone complaining.

1 Like

What I tried, I made a copy of a full machine after a reboot with image software Acronis. I used another PC installed the image, rename the machine to farmer-4 etc different IP then chia init the \Ca folder that was copied to a temp folder c:\files\ca then loaded the GUI just to try it out. It worked, shut down the GUI rebooted the machine then installed the light wallet no problems. Now I have have done extra steps but for me it worked and I didn’t kill any working machine. Just like when 1.2.12 is released (not beta) that machine will get it first.

1 Like

Ok… so I tried it. The Light wallet seup removed the farmer, AND the plotters.
It added a “standalone_wallet” directory to the [.chia] folder.
Directory of C:\Users********.chia
01/11/2022 10:55 AM mainnet
01/22/2022 06:24 PM standalone_wallet

And it turned the mainnet directory from this:
Directory of C:\Users*********.chia\mainnet
04/10/2021 15:28 cache
20/01/2022 10:25 config
20/01/2022 10:21 db
22/01/2022 18:33 log
22/01/2022 17:59 plotter
08/11/2021 09:39 plotters
22/01/2022 17:59 run
08/05/2021 01:16 wallet

To this:

Directory of C:\Users**********.chia\mainnet
01/11/2022 10:55 AM cache
05/09/2021 06:53 PM config
01/11/2022 10:56 AM db
05/09/2021 06:53 PM log
01/11/2022 10:56 AM run
05/09/2021 06:53 PM wallet

Plotter and Plotters folders went poof.
[C:\Users*******\AppData\Local\chia-blockchain\app-1.2.11\resources\app.asar.unpacked\daemon] was gone too

So yeah… there you go. ¯_(ツ)_/¯

Right, it completely overwrites the installed chia application, so you can’t run into in parallel unless you install it using the protocol_and_cats branch.

1 Like

Yeah I just reinstalled the main setup so I can plot again in that machine. I just wanted to check the light wallet up and the CATs.
I’ll just wait for the new version where they can coexist side by side.


1 Like

I hear ya. The light wallet is great.

I must apologise, I clearly didn’t comprehend your initial statement well.
To my mind you were plotting on that machine, it didn’t register in my mind you’d installed chia to do so.
Guess I’m used to ppl just using mm now with chia not installed.
Still an easy fix, glad your back to normal.

Yeah I plot using the chia official plotter. I assumed the safest way of getting the binaries was to just run the main setup on the machine. /shrug. :slight_smile:


It may be now, as I think they incorporated madmax plotter into the gui.
I’ve not used the gui plotter for many months, once I learnt to use madmax when it was stand alone I just continued to do so as I think many others did.
That way you just need to download madmax and dont need the gui or pvt keys on your plotter.

Do you know if it is madmax your using in the gui?
Gui plotter used to be many times slower compared to mm.

No I dont use the GUI, I use the CLI command line executing the chia.exe plotter from powershell.
I should try madmax. Really

1 Like

Cli or gui will call same plotter.
I was just curious if it was still as fast as stand alone mm.

Hope this helps, this is my test machine 1.2.12184 beta


I wonder if there’s speed differente with that new official chia plotter version

Ah, ok, you can choose.
Maybe there’s flags to call it to use mm from cli over the basic plotter, which is so slow in comparison.

1 Like

Yes, I’m plotting my first plot using madmax from the command line.

Instead of “chia.exe plots create” it’s “chia.exe plotters madmax”, with almost all the same parameters.
I found that for the madmax variant I had to tweak some parameters, like the temp2 dir is not disabled by default in madmax and it wants to use its own system dir for temp dir 2.
But all in all it’s pretty much straightforward.
I noticed the default buckets # is doubled in madmax. so far it does look to go faster. I’ll know for sure after several runs.

From [CLI Commands Reference · Chia-Network/chia-blockchain Wiki · GitHub]

usage: chia plotters madmax [-h] [-k SIZE] [-n COUNT] [-r THREADS] [-u BUCKETS] [-v BUCKETS3] [-t TMPDIR] [-2 TMPDIR2] [-d FINALDIR] [-w]

Madmax Plotter

optional arguments:
-h, --help show this help message and exit
-k SIZE, --size SIZE K value.
-n COUNT, --count COUNT
Number of plots to create (default = 1)
-r THREADS, --threads THREADS
Num threads.
-u BUCKETS, --buckets BUCKETS
Number of buckets.
-v BUCKETS3, --buckets3 BUCKETS3
Number of buckets for phase 3+4 (default = 256)
-t TMPDIR, --tmp_dir TMPDIR
Temporary directory 1.
-2 TMPDIR2, --tmp_dir2 TMPDIR2
Temporary directory 2.
-d FINALDIR, --final_dir FINALDIR
Final directory.
-w, --waitforcopy Wait for copy to start next plot
-p POOL_KEY, --pool-key POOL_KEY
Pool Public Key (48 bytes)
Farmer Public Key (48 bytes)
-c CONTRACT, --contract CONTRACT
Pool Contract Address (64 chars)
-G, --tmptoggle Alternate tmpdir/tmpdir2 (default = false)
-K RMULTI2, --rmulti2 RMULTI2
Thread multiplier for P2 (default = 1)


What the s/%/?

First go with madmax plotter:
Total plot creation time was 7024.33 sec (117.072 min)

A bit over 2 hours with madmax, using 2 threads and the default 256 buckets.
With official plotter it takes 7-8 hours with max (128 ) buckets, and 2 threads.
Same machine of course, wth? :stuck_out_tongue:

1 Like