Linux GUI doesn't show plots and Pool NFT

I installed chia 1.3.2-dev0 on a Ubuntu 20.04 server. I created 1 plot with the CLI to test everything. Then I started the GUI and tried to join the pool It took a while until the transaction went through, but after that nothing shows in the GUI under Pool. I tried 2 more times with the same result. Also, the plot I created before doesn’t show in the GUI.

According to the CLI, everything looks ok. chia plot check shows the plot and chia plotnft show “FARMING TO POOL” with the correct pool url.

Is this a known problem with the GUI? The only problem I read about here was with v1.3.1 on Windows

Creating the plot from the CLI doesn’t tell the node where to find the plots; it only creates them. To tell Chia where to find the plots, you need to use chia plots add -d $DIR where $DIR is the plot directory.

From the GUI, you can add the plot directory by clicking the “…” icon next to “Add a plot” and choosing “Add Plot Directory”.

Once the directory is added, the plot(s) appear and then farming/harvesting will begin.

You can also update the config manually, by adding to plot_directories found under the harvester options.

Of course, I know that. When I click “Add Plot Directory” the directory with the plot is already there. I can remove it and add it again, but nothing appears. Also “Refresh Plots” doesn’t do anything.

The directory is already in there

There are three places (in UI) that show whether the lower levels see your plots:

  1. Farm / Plot Count - usually slow with updates
  2. Farm / Last Attempted Proof - by default it should show in max 2 minutes (folder refresh timeout)
  3. Pool / Number of Plots - also maybe slow to refresh

You can also tail your debug.log, and grep for “harvester.” Every 2 minutes, harvester will search all included folders, and show how many plots it has. So, there is an initial delay here as well, but this is the best place to look for.

I don’t think it is a know problem, although it has been known to happen. But there can be a bundle of reasons why/how that can happen.

My first culprit to look at would be the fact that your are running a “dev” version and not a release version.

I did not knowingly install a dev version. I followed the guide installing the “latest” git branch.

$ git branch
* latest

Somewhere in the install guide, there is mention of this how to change to release version.
It’s an annoying thing that it always takes the latest version even if it’s dev version.

Or you can just install the installer package for Linux.

However, not sure of course if this is the problem or not.

Other issues might involve different keys in the CLI input or something like that.
Maybe just try to create a plot via the GUI and see how that goes, narrows the list of possibilities a bit.

latest is never a dev version. Releases and dev versions are in other branches, and latest points to the most recent, stable (i.e. non-dev, non-alpha/beta) version (currently 1.3.1).

The main branch is going to have all commits since the latest branch for the next release and would be considered a development branch. Use the latest branch if you want to build the latest stable release.

1 Like

I don’t remember clearly anymore what the issue was, it’s been a while since installed on Linux, but I seem to remember that if you download and install the package from the console it could happen that you could get a dev version ,so you had to pay attention there.

anyway, important part is that OP use a release version instead of dev